Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

dnf update error on glib2

The downloaded packages were saved in cache until the next successful transaction. You can remove cached packages by executing 'dnf clean packages'. Error: Transaction check error: file /usr/share/glib-2.0/codegen/__pycache__/codegen_main.cpython-36.opt-1.pyc conflicts between attempted installs of glib2-devel-2.56.1-2.fc28.i686 and glib2-devel-2.56.1-2.fc28.x86_64 file /usr/share/glib-2.0/codegen/__pycache__/codegen_main.cpython-36.pyc conflicts between attempted installs of glib2-devel-2.56.1-2.fc28.i686 and glib2-devel-2.56.1-2.fc28.x86_64

any ideas? I considered removing glib2-devel, but it takes away a large number of dependent files, so I did not want to do that. Does anyone else have this same issue? Thanks.