Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

How to disable lid closed sensor - tablet mode

Background: I use a thinkpad X220t, and I often need to put it in tablet mode for writing. For the past year or so, every time I turn the monitor and put it in tablet mode, the screen turns off, just the screen. It depends on the angle between the monitor and keyboard, and weirdly, the threshold has increased over time. I have tried to tweak the settings of close-lid but it seems like the only options that I have change the settings for when the lid is closed normally, and not in the tablet mode (i.e. when the monitor is turned).

Question: How can I turn off the sensor completely so that fedora doesn't realise the lid is being closed?

I'm hoping to use this temporarily until I find a fix (which now I'm guessing that it could be a hardware problem).

How to disable lid closed sensor - tablet mode

Background: I use a thinkpad X220t, and I often need to put it in tablet mode for writing. For the past year or so, every time I turn the monitor and put it in tablet mode, the screen turns off, just the screen. It depends on the angle between the monitor and keyboard, and weirdly, the threshold has increased over time. I have tried to tweak the settings of close-lid but it seems like the only options that I have change the settings for when the lid is closed normally, and not in the tablet mode (i.e. when the monitor is turned).

Question: How can I turn off the close-lid sensor completely (including the tablet mode) so that fedora doesn't realise the lid is being closed?

I'm hoping to use this temporarily until I find a fix (which now I'm guessing that it could be a hardware problem).

How to disable lid closed sensor - tablet mode

Background: I use a thinkpad X220t, and I often need to put it in tablet mode for writing. For the past year or so, every time I turn the monitor and put it in tablet mode, the screen turns off, just the screen. It depends on the angle between the monitor and keyboard, and weirdly, the threshold has increased over time. I have tried to tweak the settings of close-lid but it seems like the only options that I have change the settings for when the lid is closed normally, and not in the tablet mode (i.e. when the monitor is turned).

Question: How can I turn off the close-lid sensor completely (including the tablet mode) so that fedora doesn't realise the lid is being closed?

I'm hoping to use this temporarily until I find a fix (which now I'm guessing that it could be a hardware problem).

UPDATE: I've changed the settings in /etc/systemd/logind.conf to

HandleLidSwitch=ignore
HandleLidSwitchDocked=ignore

and it didn't help.

How to disable lid closed sensor - tablet mode

Background: I use a thinkpad X220t, and I often need to put it in tablet mode for writing. For the past year or so, every time I turn the monitor and put it in tablet mode, the screen turns off, just the screen. It depends on the angle between the monitor and keyboard, and weirdly, the threshold has increased over time. I have tried to tweak the settings of close-lid but it seems like the only options that I have change the settings for when the lid is closed normally, and not in the tablet mode (i.e. when the monitor is turned).

Question: How can I turn off the close-lid sensor completely (including the tablet mode) so that fedora doesn't realise the lid is being closed?

I'm hoping to use this temporarily until I find a fix (which now I'm guessing that it could be a hardware problem).

UPDATE: I've changed the settings in /etc/systemd/logind.conf to

HandleLidSwitch=ignore
HandleLidSwitchDocked=ignore

and it didn't help.

UPDATE 2: When I run sudo acpitool -w, this is the output I get

   Device   S-state   Status   Sysfs node
  ---------------------------------------
  1. LID      S3    *enabled   platform:PNP0C0D:00
  2. SLPB     S3    *enabled   platform:PNP0C0E:0

Which then I can enable or disable either of them. I did disable both and the screen turns off with any combination of on and off for the 2 devices listed above.