Ask Your Question

Revision history [back]

Turbo boost gets "unsupported" during runtime

Hi, I have an Intel i7-7500U processor(Lenovo Yoga 510 if that matters). I'm using kernel 4.12.5-300.fc26.x86_64, also tried the newest kernel in the repos, however I have the following problem:

When I boot my laptop, turbo boost is "supported" as reported by cpupower frequency-info. However, after some time it gets "unsupported", I get the following output:

analyzing CPU 0:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency:  Cannot determine or is not supported.
  hardware limits: 400 MHz - 3.50 GHz
  available cpufreq governors: performance powersave
  current policy: frequency should be within 400 MHz and 2.70 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency: 2.70 GHz (asserted by call to hardware)
  boost state support:
    Supported: no
    Active: no

Right after boot, it was

  boost state support:
    Supported: yes
    Active: yes

As a result, the processor cannot achieve its boost state, which is 3.50GHz. At first I though that this was because the CPU is getting warmer and that's why it needed to be on a lower frequency, but this is not the case - it seems that the CPU is at only +43.0°C, whereas I've seen it run at +70 when under heavy load. Can anyone help me to resolve the problem?