Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

After migration of LVM PE to new PV, boot fails

I've been running encrypted PV in LVM for many years. root is on an LV on the encrypted PV. Booting used to work fine and would prompt for PV LUKS passphrase and then find all LVs inside, start them automatically, mount root and continue booting.

I created a new PV, encrypted it with LUKS, like before, put it in my VG and migrated all the PEs from the old PV to the new PV. Now, when I try to boot, it prompts to unlock the old PV --I can tell because the UUID is the old PV UUID.

This makes some sense since grub shows the old UUID on the kernel command line. But, I've tried to fix it a number of different ways, and nothing has worked. For example, if I remove the old parameter and try rd.auto=1, it will prompt to unlock the new PV, and succeeds, but it doesn't start LVM and find the root LV and boot; it just stalls.

How do I reconfigure grub and dracut properly? I cannot boot the system, remember. Clearly, one or both of these do not contain the right configuration, but I don't understand why since none of the LV names or UUIDs have changed, which is what I thought was in initrd.