Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Error when installing sass using "gem install sass"

This is the output I get when trying to install sass with gem. I have ruby / rubygems installed. I've tried intalling make, ruby-devel and some other packages. Nothing resolved the issue. Any help?

Building native extensions. This could take a while... ERROR: Error installing sass: ERROR: Failed to build gem native extension.

current directory: /usr/local/share/gems/gems/ffi-1.9.18/ext/ffi_c

/usr/bin/ruby -r ./siteconf20170825-13240-1f9wvqf.rb extconf.rb checking for ffi.h... * extconf.rb failed * Could not create Makefile due to some reason, probably lack of necessary libraries and/or headers. Check the mkmf.log file for more details. You may need configuration options.

Provided configuration options: --with-opt-dir --without-opt-dir --with-opt-include --without-opt-include=${opt-dir}/include --with-opt-lib --without-opt-lib=${opt-dir}/lib64 --with-make-prog --without-make-prog --srcdir=. --curdir --ruby=/usr/bin/$(RUBY_BASE_NAME) --with-ffi_c-dir --without-ffi_c-dir --with-ffi_c-include --without-ffi_c-include=${ffi_c-dir}/include --with-ffi_c-lib --without-ffi_c-lib=${ffi_c-dir}/lib64 --with-libffi-config --without-libffi-config --with-pkg-config --without-pkg-config /usr/share/ruby/mkmf.rb:457:in try_do': The compiler failed to generate an executable file. (RuntimeError) You have to install development tools first. from /usr/share/ruby/mkmf.rb:588:intry_cpp' from /usr/share/ruby/mkmf.rb:1095:in block in have_header' from /usr/share/ruby/mkmf.rb:945:inblock in checking_for' from /usr/share/ruby/mkmf.rb:351:in block (2 levels) in postpone' from /usr/share/ruby/mkmf.rb:321:inopen' from /usr/share/ruby/mkmf.rb:351:in block in postpone' from /usr/share/ruby/mkmf.rb:321:inopen' from /usr/share/ruby/mkmf.rb:347:in postpone' from /usr/share/ruby/mkmf.rb:944:inchecking_for' from /usr/share/ruby/mkmf.rb:1094:in have_header' from extconf.rb:16:in<main>'

To see why this extension failed to compile, please check the mkmf.log which can be found here:

/usr/local/lib64/gems/ruby/ffi-1.9.18/mkmf.log

extconf failed, exit code 1

Gem files will remain installed in /usr/local/share/gems/gems/ffi-1.9.18 for inspection. Results logged to /usr/local/lib64/gems/ruby/ffi-1.9.18/gem_make.out

click to hide/show revision 2
No.2 Revision

updated 2017-08-25 05:51:41 -0500

hhlp gravatar image

Error when installing sass using "gem install sass"

This is the output I get when trying to install sass with gem. I have ruby / rubygems installed. I've tried intalling make, ruby-devel and some other packages. Nothing resolved the issue. Any help?

Building native extensions. This could take a while... ERROR: Error installing sass: ERROR: Failed to build gem native extension.

 current directory: /usr/local/share/gems/gems/ffi-1.9.18/ext/ffi_c

/usr/bin/ruby -r ./siteconf20170825-13240-1f9wvqf.rb extconf.rb checking for ffi.h... * *** extconf.rb failed * *** Could not create Makefile due to some reason, probably lack of necessary libraries and/or headers. Check the mkmf.log file for more details. You may need configuration options.

options. Provided configuration options: --with-opt-dir --without-opt-dir --with-opt-include --without-opt-include=${opt-dir}/include --with-opt-lib --without-opt-lib=${opt-dir}/lib64 --with-make-prog --without-make-prog --srcdir=. --curdir --ruby=/usr/bin/$(RUBY_BASE_NAME) --with-ffi_c-dir --without-ffi_c-dir --with-ffi_c-include --without-ffi_c-include=${ffi_c-dir}/include --with-ffi_c-lib --without-ffi_c-lib=${ffi_c-dir}/lib64 --with-libffi-config --without-libffi-config --with-pkg-config --without-pkg-config /usr/share/ruby/mkmf.rb:457:in try_do': `try_do': The compiler failed to generate an executable file. (RuntimeError) You have to install development tools first. from /usr/share/ruby/mkmf.rb:588:intry_cpp' /usr/share/ruby/mkmf.rb:588:in `try_cpp' from /usr/share/ruby/mkmf.rb:1095:in block `block in have_header' from /usr/share/ruby/mkmf.rb:945:inblock /usr/share/ruby/mkmf.rb:945:in `block in checking_for' from /usr/share/ruby/mkmf.rb:351:in block `block (2 levels) in postpone' from /usr/share/ruby/mkmf.rb:321:inopen' /usr/share/ruby/mkmf.rb:321:in `open' from /usr/share/ruby/mkmf.rb:351:in block `block in postpone' from /usr/share/ruby/mkmf.rb:321:in/usr/share/ruby/mkmf.rb:321:in `open' from /usr/share/ruby/mkmf.rb:347:in `postpone' from /usr/share/ruby/mkmf.rb:944:in `checking_for' from /usr/share/ruby/mkmf.rb:1094:in `have_header' from extconf.rb:16:in `<main>' open' from /usr/share/ruby/mkmf.rb:347:in postpone' from /usr/share/ruby/mkmf.rb:944:inchecking_for' from /usr/share/ruby/mkmf.rb:1094:in have_header' from extconf.rb:16:in<main>'

To see why this extension failed to compile, please check the mkmf.log which can be found here:

/usr/local/lib64/gems/ruby/ffi-1.9.18/mkmf.log

  /usr/local/lib64/gems/ruby/ffi-1.9.18/mkmf.log

extconf failed, exit code 1

Gem files will remain installed in /usr/local/share/gems/gems/ffi-1.9.18 for inspection. Results logged to /usr/local/lib64/gems/ruby/ffi-1.9.18/gem_make.out