Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Installing new kernel always puts new Fedora entry at the top of GRUB menu, despite my custom menu entry

I have a custom GRUB menu entry that I want to always appear at the top of the GRUB menu. This menu entry lives in /etc/grub.d/09_FIRST, so that it should appear before 10_linux. However, whenever I install system updates that include a new kernel, the new Fedora entry gets bumped to the top of the GRUB menu, until I manually run grub2-mkconfig. It was my understanding that installing a new kernel should run grub2-mkconfig --- so what's going on here?

My system:

  • Fedora 26 Workstation x86_64 with UEFI motherboard
  • grub2-2.02-0.46.fc26
  • latest kernel: 4.12.5
↪  cat /etc/default/grub
# ========== Defaults from Fedora ==========

GRUB_TIMEOUT="-1"
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DISABLE_SUBMENU="true"
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="rd.luks.uuid=luks-8e45f2c9-cbd1-45ef-b916-981302ac347f rd.luks.uuid=luks-43b66853-1753-405e-bb93-2eec26187889 rhgb quiet"
GRUB_DISABLE_RECOVERY="true"


# ========= Custom settings ==========

GRUB_TIMEOUT="-1"
GRUB_GFXMODE="auto"
GRUB_TERMINAL_OUTPUT="gfxterm"
GRUB_GFXPAYLOAD_LINUX="keep"

GRUB_SAVEDEFAULT="false"
GRUB_COLOR_NORMAL="white/black"
GRUB_COLOR_HIGHLIGHT="yellow/dark-gray"
GRUB_DEFAULT="FIRST"
GRUB_FONT="/boot/efi/EFI/fedora/themes/DejaVuSansMono.pf2"

Installing new kernel always puts new Fedora entry at the top of GRUB menu, despite my custom menu entry

I have a custom GRUB menu entry that I want to always appear at the top of the GRUB menu. This menu entry lives in /etc/grub.d/09_FIRST, so that it should appear before 10_linux. However, whenever I install system updates that include a new kernel, the new Fedora entry gets bumped to the top of the GRUB menu, until I manually run grub2-mkconfig. It was my understanding that installing a new kernel should run grub2-mkconfig --- so what's going on here?

My system:

  • Fedora 26 Workstation x86_64 with UEFI motherboard
  • grub2-2.02-0.46.fc26
  • latest kernel: 4.12.5
↪  cat /etc/default/grub
# ========== Defaults from Fedora ==========

GRUB_TIMEOUT="-1"
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DISABLE_SUBMENU="true"
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="rd.luks.uuid=luks-8e45f2c9-cbd1-45ef-b916-981302ac347f rd.luks.uuid=luks-43b66853-1753-405e-bb93-2eec26187889 rhgb quiet"
GRUB_DISABLE_RECOVERY="true"


# ========= Custom settings ==========

GRUB_TIMEOUT="-1"
GRUB_GFXMODE="auto"
GRUB_TERMINAL_OUTPUT="gfxterm"
GRUB_GFXPAYLOAD_LINUX="keep"

GRUB_SAVEDEFAULT="false"
GRUB_COLOR_NORMAL="white/black"
GRUB_COLOR_HIGHLIGHT="yellow/dark-gray"
GRUB_COLOR_HIGHLIGHT="black/white"
GRUB_DEFAULT="FIRST"
GRUB_FONT="/boot/efi/EFI/fedora/themes/DejaVuSansMono.pf2"

Installing new kernel always puts new Fedora entry at the top of GRUB menu, despite my custom menu entry

I have a custom GRUB menu entry that I want to always appear at the top of the GRUB menu. This menu entry lives in /etc/grub.d/09_FIRST, so that it should appear before 10_linux. However, whenever I install system updates that include a new kernel, the new Fedora entry gets bumped to the top of the GRUB menu, until I manually run grub2-mkconfig. It was my understanding that installing a new kernel should run grub2-mkconfig --- so what's going on here?

My system:

  • Fedora 26 Workstation x86_64 with UEFI motherboard
  • grub2-2.02-0.46.fc26
  • latest kernel: 4.12.5
↪  cat /etc/default/grub
# ========== Defaults from Fedora ==========

GRUB_TIMEOUT="-1"
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DISABLE_SUBMENU="true"
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="rd.luks.uuid=luks-8e45f2c9-cbd1-45ef-b916-981302ac347f rd.luks.uuid=luks-43b66853-1753-405e-bb93-2eec26187889 rhgb quiet"
GRUB_DISABLE_RECOVERY="true"


# ========= Custom settings ==========

GRUB_TIMEOUT="-1"
GRUB_TIMEOUT="5"
GRUB_GFXMODE="auto"
GRUB_TERMINAL_OUTPUT="gfxterm"
GRUB_GFXPAYLOAD_LINUX="keep"

GRUB_SAVEDEFAULT="false"
GRUB_COLOR_NORMAL="white/black"
GRUB_COLOR_HIGHLIGHT="black/white"
GRUB_DEFAULT="FIRST"
GRUB_FONT="/boot/efi/EFI/fedora/themes/DejaVuSansMono.pf2"

Installing new kernel always puts new Fedora entry at the top of GRUB menu, despite my custom menu entry

I have a custom GRUB menu entry that I want to always appear at the top of the GRUB menu. This menu entry lives in /etc/grub.d/09_FIRST, so that it should appear before 10_linux. However, whenever I install system updates that include a new kernel, the new Fedora entry gets bumped to the top of the GRUB menu, until I manually run grub2-mkconfig. It was my understanding that installing a new kernel should run grub2-mkconfig --- so what's going on here?

My system:

  • Fedora 26 Workstation x86_64 with UEFI motherboard
  • grub2-2.02-0.46.fc26
  • latest kernel: 4.12.5
↪  cat /etc/default/grub
# ========== Defaults from Fedora ==========

GRUB_TIMEOUT="-1"
GRUB_TIMEOUT="5"
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DISABLE_SUBMENU="true"
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="rd.luks.uuid=luks-8e45f2c9-cbd1-45ef-b916-981302ac347f rd.luks.uuid=luks-43b66853-1753-405e-bb93-2eec26187889 rhgb quiet"
GRUB_DISABLE_RECOVERY="true"


# ========= Custom settings ==========

GRUB_TIMEOUT="5"
GRUB_TIMEOUT="-1"
GRUB_GFXMODE="auto"
GRUB_TERMINAL_OUTPUT="gfxterm"
GRUB_GFXPAYLOAD_LINUX="keep"

GRUB_SAVEDEFAULT="false"
GRUB_COLOR_NORMAL="white/black"
GRUB_COLOR_HIGHLIGHT="black/white"
GRUB_DEFAULT="FIRST"
GRUB_FONT="/boot/efi/EFI/fedora/themes/DejaVuSansMono.pf2"