Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Grub installation freeze

Now this appears to happen not only with Fedora, but also other distros I've tried in the expectation it might have been a Fedora-specific bug.

I have an old HP Pavilion P2-1124 that I want to use for a "server" for my scanner, allowing scanned documents to be transferred to it. Not much of a system demand then.

The system came with Windows 7 Home Premium but even as it came from the factory, was very slow.

I decided instead to just install Fedora on it, minimal system with LXDE, from a DVD-ROM.

Everything works fine until it gets to the installation of GRUB, I think, at which point it FREEZES. At first I thought maybe the system was just taking a long time to install, so I left it overnight. Nope, frozen solid.

Since the attempt at Fedora I have tried Lubuntu and Arch-Linux. Lubuntu hung at about the same relative point int he install (it isn't quite as transparent. The Arch-Linux install was more insightful, since you do everything by hand from the command line. I was able to get it to boot to the install environment, partition the HD, and CHROOT into the new system. But when I got to the point of installing GRUB on the /boot partition, once again, it HUNG UP! Again, left it all night, again, frozen solid.

I am unfamiliar with the vagaries of EFI, but I suspect that has something to do with the problem. My research indicates that earlier EFI implementations were all over the place, with no one standard, and the EFI interface on this machine is very unhelpful. I have looked but am unable to find any sort of firmware update for this machine.

The Motherboard, FWIW, is a Pegatron APXD1-DM (Bluewood3) with a 64-bit AMD Fusion E300 (Zacate) Dual Core APU processor soldered to the motherboard. I have used both 500GB and 2TB Seagate HDs in my install attempts.

I'd love some suggestions as to how I might resolve this problem.