Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

grub normal.mod missing, how to fix?

Can anyone help me with this?? I ran into this problem while changing my wireless adapter, after i changed it, my pc cannot be turn on, after attempt to reinstall it and finally managed to turned on. But the big problem comes, normal.mod is not found, and i stuck at this grub rescue for hours. Tried restore UEFI/bios settings to default but didn't help. I had also tried to ls the all the hdX partition, with /boot, but still can't find it. as follows: image description

May i know what should i do now?? how to find the normal.mod or recover GRUB?? My hard disk structure:

128GB SSD

|- -/dev/sda1

|--/dev/sda2

|--/dev/sda3

1TB HDD

|--/dev/sdb

500GB HDD

|--/dev/sdc1

|--/dev/sdc2

|--/dev/sdc5

|--/dev/sdc6

320GB HDD

|--/dev/sdd1

|--/dev/sdd2

My hdd partition are as follows(loaded using live cd) image description

My main harddisk, with fedora installed(LVM) image description

The rest:

image description image description image description

grub normal.mod missing, how to fix?

Can anyone help me with this?? I ran into this problem while changing my wireless adapter, adapter(swap), after i changed it, my pc cannot be turn on, after attempt to reinstall it and finally managed to turned on. But the big problem comes, normal.mod is not found, and i stuck at this grub rescue for hours. Tried restore UEFI/bios settings to default but didn't help. I had also tried to ls the all the hdX partition, with /boot, but still can't find it. as follows: image description

May i know what should i do now?? how to find the normal.mod or recover GRUB?? ??

UPDATE: In grub rescue, i was not able to view contents of My SSD(lvm) which the OS is installed.

My hard disk structure:

128GB SSD (hd1)-unable to load SSD's content in grub rescue

|- -/dev/sda1

|--/dev/sda2

|--/dev/sda3

1TB HDD

|--/dev/sdb (hd2)~ext4

|--/dev/sdb

500GB HDD

|--/dev/sdc1 (hd0)

|--/dev/sdc1 (hd0,1)~ext4

|--/dev/sdc2

|--/dev/sdc5

|--/dev/sdc6
|--/dev/sdc5 (hd0,5)~ntfs,unable to view

|--/dev/sdc6 (hd0,6)~ext4

320GB HDD

|--/dev/sdd1

|--/dev/sdd2 (hd3)

|--/dev/sdd1 (hd3,1)~ext4

|--/dev/sdd2 (hd3,2)~ntfs, unable to open

My hdd partition are as follows(loaded using live cd) image description

My main harddisk, with fedora installed(LVM) image description

The rest:

image description image description image description

grub normal.mod missing, how to fix?

Can anyone help me with this?? I ran into this problem while changing my wireless adapter(swap), after i changed it, my pc cannot be turn on, after attempt to reinstall it and finally managed to turned on. But the big problem comes, normal.mod is not found, and i stuck at this grub rescue for hours. Tried restore UEFI/bios settings to default but didn't help. I had also tried to ls the all the hdX partition, with /boot, but still can't find it. as follows: image description

May i know what should i do now?? how to find the normal.mod or recover GRUB??

UPDATE: In grub rescue, i was not able to view contents of My SSD(lvm) which the OS is installed.

My hard disk structure:

128GB SSD (hd1)-unable to load SSD's content in grub rescue

|- -/dev/sda1

|--/dev/sda2

|--/dev/sda3

1TB HDD (hd2)~ext4

|--/dev/sdb

500GB HDD (hd0)

|--/dev/sdc1 (hd0,1)~ext4

|--/dev/sdc2

|--/dev/sdc5 (hd0,5)~ntfs,unable to view

|--/dev/sdc6 (hd0,6)~ext4

320GB HDD (hd3)

|--/dev/sdd1 (hd3,1)~ext4

|--/dev/sdd2 (hd3,2)~ntfs, unable to open

My hdd partition are as follows(loaded using live cd) image description

My main harddisk, harddisk(SSD), with fedora installed(LVM) image description

The rest:

image description image description image description