Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Can't login to fedora 25 gnome, except by using startx from tty

Last week fedora 25 gnome software center installed a buggy gdm version on my system, I removed it but still having problems. I'm using Gdm and Wayland session.

I can't login to fedora from login page, the only way is to use tty, login, then startx

I tried many solutions, including removing Xauthority, chmod temp -R 755 or something and many other solutions but nothing worked.

What bother me the most is that I faced this same issue many years back on ubuntu and solved it but can't remember what I did! Hell I might have even solved it on Crunchbang many years ago!

the log file of startx

  xauth:  file /home/user/.serverauth.1830 does not exist
    X.Org X Server 1.19.1
    Release Date: 2017-01-11
    X Protocol Version 11, Revision 0
    Build Operating System:  4.10.0-0.rc4.git0.2.fc26.x86_64 
    Current Operating System: Linux fedora 4.9.13-201.fc25.x86_64 #1 SMP Tue Mar 7 23:47:11 UTC 2017 x86_64
    Kernel command line: BOOT_IMAGE=/vmlinuz-4.9.13-201.fc25.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet LANG=en_US.UTF-8
    Build Date: 01 February 2017  02:03:54AM
    Build ID: xorg-x11-server 1.19.1-3.fc25 
    Current version of pixman: 0.34.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/home/user/.local/share/xorg/Xorg.1.log", Time: Sun Mar 12 14:37:10 2017
    (==) Using config directory: "/etc/X11/xorg.conf.d"
    (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
    (II) [KMS] Kernel modesetting enabled.
    pkexec version 0.113

If it can't be solved, I'll switch to lightdm or kdm