Ask Your Question
0

Selinux and Firewalld dependencies issues after upgrade to F24 [closed]

asked 2017-01-09 15:42:15 -0500

edwardc01 gravatar image

I finally got my system to upgrade to F24 but I had to remove 18 packages to clear all dependencies issues before dnf would run the upgrade. However after upgrade completes and system boots everything seems normal but the next morning I have 84 packages to ugrade with 4 that have broken dependencies. dnf --allowerasing doesn't help. I get the following output from dnf upgrade --best: Error: package firewalld-0.4.4.2-2.fc24.noarch conflicts with selinux-policy < 3.13.1-191.23 provided by selinux-policy-3.13.1-191.21.fc24.noarch. package selinux-policy-targeted-3.13.1-191.21.fc24.noarch requires selinux-policy = 3.13.1-191.21.fc24, but none of the providers can be installed. package firewalld-0.4.1.2-1.fc24.noarch requires firewalld-filesystem = 0.4.1.2-1.fc24, but none of the providers can be installed. package firewalld-0.4.1.2-1.fc24.noarch requires python3-firewall = 0.4.1.2-1.fc24, but none of the providers can be installed (try to add '--allowerasing' to command line to replace conflicting packages)

I can find some mention of similar problems but no solutions.

Any help appreciated. Need to get stable and re-install my packages I had to delete to upgrade.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by edwardc01
close date 2017-01-10 14:29:07.911285

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-01-09 18:36:06 -0500

sergiomb gravatar image

Should be fixed in some hours when https://bodhi.fedoraproject.org/updat... get pushed to F24 updates stable , another option is :

dnf --enablerepo=updates-testing update "firewall*"
edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-01-09 15:42:15 -0500

Seen: 245 times

Last updated: Jan 09 '17