Ask Your Question
0

Intel Fortran Compiler [closed]

asked 2012-12-15 15:04:07 -0600

aerospacee88 gravatar image

updated 2012-12-17 01:29:48 -0600

Jomoos gravatar image

I just installed Intel Composer XE to use the Intel Fortran Compiler. I set the environment variables by running /opt/intel/bin/ifortvars.sh intel64 but ifort still doesn't work. Any help is appreciated

[root@localhost bin]# ls
codecov           idb            ifortvars.sh   link_install.sh  proforder
compilervars.csh  idbc           inspxe-inject  map_opts         tselect
compilervars.sh   ifort          inspxe-runsc   profdcg          xiar
fpp               ifortvars.csh  inspxe-wrap    profmerge        xild
[root@localhost bin]# ./ifortvars.sh intel64
[root@localhost bin]# man ifort
No manual entry for ifort
[root@localhost bin]# ifort
bash: ifort: command not found...
edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by FranciscoD_
close date 2013-06-13 23:01:30.500948

Comments

The first big error here is using root to run a fortran compiler.

skytux gravatar imageskytux ( 2013-06-13 19:06:08 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-06-13 17:32:55 -0600

dfcesar gravatar image

updated 2013-06-13 17:37:00 -0600

I have faced the same problem, and the solution, in my case, was add to my .bashrc:

export LDLIBRARYPATH="/opt/intel/versao/lib"

export DYLDLIBRARYPATH="/opt/intel/versao/lib"

export MANPATH="/opt/intel/man"

export PATH=/opt/intel/versao/bin:$PATH

After reload the bash with:

$ source .bashrc

try:

$ ifort -v

ifort version 13.1.2

That's all.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-12-15 15:04:07 -0600

Seen: 1,569 times

Last updated: Jun 13 '13