How do you disable Autoswitch for headphones in FC23+?

asked 2017-01-08 06:08:00 -0500

I have a Dell Precision M6700 and the Dell hardware automatically switches the audio output from the speakers to headphones and expects input only on the speakers OS output. Every time I plug in the headphones I have to manually switch the audio output from headphones to speakers and sound works fine. Currently running FC 23. Was going to just go with odd releases but can update to 24 if needed. As this is my only and primary work desktop I try to update every other release.

Thx!

Steven Mercurio RHCE, RHCVA, RHCDAdoes the switch internally from

edit retag flag offensive close merge delete

Comments

You could try to comment the following line in /etc/pulse/default.pa.

load-module module-switch-on-port-available

If there is a .config/pulse/default.pa, check that file as well. I think you have to logout/login to make the changes active.

thomaswood gravatar imagethomaswood ( 2017-01-08 08:16:13 -0500 )edit