Ask Your Question
0

Fedora 17 - Automatic bug report always warn on startup: 'kernel - Your BIOS is broken

asked 2012-07-08 05:43:00 -0500

Peter Roos gravatar image

I have installed Fedora 17 on my laptop 3 days ago. Works flawlessly, but I always get this message on startup by automatic bug report tool on the left down corner. Detailed screenshot.

What does it mean, how can I resolve this?

I will only have to opportunity to update this stock Fedora in a few days though, as I'm now on mobile internet. But this says something about my BIOS... doesn't look like updates would solve this.

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
0

answered 2012-09-02 02:49:44 -0500

andreu gravatar image

updated 2012-09-04 08:29:11 -0500

before upgrading all right with iommu = off editing grub is fixed add iommu = off sudo gedit /boot/grub2/grub.cfg danger....

menuentry 'Fedora' --class fedora
--class gnu-linux --class gnu --class os $menuentry_id_option
'gnulinux-simple-1133b342-e20a-48e6-9a77-b85c232c1c5b' {
      **iommu=off *add this in menuentry and submenu***     load_video
    set gfxpayload=keep     insmod gzio
    insmod part_msdos   insmod ext2     set
root='hd1,msdos1'

After update the problem return and fix it upgrading the bios and unprotect bios write

edit flag offensive delete link more
0

answered 2012-09-04 18:14:03 -0500

davidva gravatar image

This is not a direct solution to the problem. but, if you do not want to display the message, you could change SELinux to permissive mode or disable it. Is not recommended because, SELinux is a Linux feature that provides the mechanism for supporting access control security policies.

How to change to permisive mode (recommended)

su

cp /etc/selinux/config /etc/selinux/config.bak

sudo gedit /etc/selinux/config

change SELINUX=enforcing for SELINUX=permisive

How to disable

su

cp /etc/selinux/config /etc/selinux/config.bak

sudo gedit /etc/selinux/config

change SELINUX=enforcing for SELINUX=disabled
edit flag offensive delete link more
0

answered 2012-09-05 03:08:14 -0500

gasdim gravatar image

There is a bug with the default kernel. Check here

edit flag offensive delete link more
0

answered 2012-07-30 17:14:15 -0500

updated 2012-09-02 09:18:00 -0500

hhlp gravatar image

I Have the same issue in Fedora 17:

WARNING: at drivers/iommu/dmar.c:492 warn_invalid_dmar+0x92/0xa0()

I have the lates Bios update from Windows 7 i downloaded and installed the official drivers. The message continue. Please help.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2012-07-08 05:43:00 -0500

Seen: 1,561 times

Last updated: Sep 05 '12