Ask Your Question
0

Bluetooth headset connection defaults to HSP/HFP or wrong output when reconnected in Fedora

asked 2017-01-06 08:50:47 -0500

Serega.Osipov gravatar image

updated 2017-01-06 13:32:45 -0500

Problem is very simple, every time I power on my Bluedio Bluetooth headphones I hear device connected, however, sound is not being output anywhere, I have to go to Bluetooth settings and manually reconnect the devices after which I hear additional beep sound and headphones work properly as A2DP profile. It seems that if I open bluetooth settings panel before powering on the headphones and manually choose to pair, then headphones will also work properly.

Is there are a way to have sound output properly by default to the headphones as soon as they are connected?

This behavior is persistent across all of the Fedora 21 to 24.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-01-06 15:26:19 -0500

Period22 gravatar image

updated 2017-01-06 15:52:53 -0500

The following has helped me with a similar but not identical problem. You could try! From: https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#AutomaticallyswitchtoBluetoothorUSBheadset

Automatically switch to Bluetooth or USB headset

Add the following:

/etc/pulse/default.pa

# automatically switch to newly-connected devices
load-module module-switch-on-connect

I had to manually set the connection to A2DP but only once.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2017-01-06 08:50:47 -0500

Seen: 1,156 times

Last updated: Jan 06 '17