Ask Your Question
1

Fedora 24 - Can't establish PPTP vpn

asked 2017-01-02 13:55:20 -0600

Morrow1501 gravatar image

updated 2017-01-03 11:00:43 -0600

Hi guys,

This is my first time posting, I have always found solutions to my problem in this ASK sub-forum, but this time I couldn't.

I can't connect to a simple PPTP VPN.

MORE INFO:
-SELinux is in permissive mode
-I got other VPN connections -VPNC-, which work.

I'll post here the logs I found in journalctl :

Jan 02 20:43:26 localhost.localdomain NetworkManager[1038]: <info>  [1483386206.1996] audit: op="connection-activate" uuid="b4b1ba39-4bb4-4e6c-bde3-aab5cef07279" name="VPN1" pid=1761 uid=1000 result="success"
Jan 02 20:43:26 localhost.localdomain NetworkManager[1038]: <info>  [1483386206.2062] vpn-connection[0x55dc9f0c93e0,b4b1ba39-4bb4-4e6c-bde3-aab5cef07279,"VPN1",0]: Started the VPN service, PID 7786
Jan 02 20:43:26 localhost.localdomain NetworkManager[1038]: <info>  [1483386206.2137] vpn-connection[0x55dc9f0c93e0,b4b1ba39-4bb4-4e6c-bde3-aab5cef07279,"Padovastar",0]: Saw the service appear; activating connection
Jan 02 20:43:30 localhost.localdomain NetworkManager[1038]: <info>  [1483386210.0462] keyfile: update /etc/NetworkManager/system-connections/VPN1 (b4b1baSELECT al.thrd "Thread", almax "Last Seq Received", lhmax "Last Seq Applied" FROM (select thread# thrd, MAX(sequence#) almax FROM v$archived_log WHERE resetlogs_change#=(SELECT resetlogs_change# FROM v$database) GROUP BY thread#) al, (SELECT thread# thrd, MAX(sequence#) lhmax FROM v$log_history WHERE resetlogs_change#=(SELECT resetlogs_change# FROM v$database) GROUP BY thread#) lh WHERE al.thrd = lh.thrd;39-4bb4-4e6c-bde3-aab5cef07279,"VPN1")
Jan 02 20:43:30 localhost.localdomain NetworkManager[1038]: <info>  [1483386210.0583] vpn-connection[0x55dc9f0c93e0,b4b1ba39-4bb4-4e6c-bde3-aab5cef07279,"VPN1",0]: VPN connection: (ConnectInteractive) reply received
Jan 02 20:43:30 localhost.localdomain NetworkManager[1038]: ** Message: pppd started with pid 7805
Jan 02 20:43:30 localhost.localdomain NetworkManager[1038]: <info>  [1483386210.0611] vpn-connection[0x55dc9f0c93e0,b4b1ba39-4bb4-4e6c-bde3-aab5cef07279,"VPN1",0]: VPN plugin: state changed: starting (3)
Jan 02 20:43:30 localhost.localdomain pppd[7805]: Plugin /usr/lib64/pppd/2.4.7/nm-pptp-pppd-plugin.so loaded.
Jan 02 20:43:30 localhost.localdomain NetworkManager[1038]: Plugin /usr/lib64/pppd/2.4.7/nm-pptp-pppd-plugin.so loaded.
Jan 02 20:43:30 localhost.localdomain NetworkManager[1038]: ** Message: nm-pptp-ppp-plugin: (plugin_init): initializing
Jan 02 20:43:30 localhost.localdomain pppd[7805]: pppd 2.4.7 started by root, uid 0
Jan 02 20:43:30 localhost.localdomain NetworkManager[1038]: ** Message: nm-pptp-ppp-plugin: (nm_phasechange): status 3 / phase 'serial connection'
Jan 02 20:43:30 localhost.localdomain pppd[7805]: Using interface ppp0
Jan 02 20:43:30 localhost.localdomain NetworkManager[1038]: Using interface ppp0
Jan 02 20:43:30 localhost.localdomain NetworkManager[1038]: Connect: ppp0 <--> /dev/pts/1
Jan 02 20:43:30 localhost.localdomain NetworkManager[1038]: ** Message: nm-pptp-ppp-plugin: (nm_phasechange): status 5 / phase 'establish'
Jan 02 20:43:30 localhost.localdomain pppd[7805]: Connect: ppp0 <--> /dev/pts/1
Jan 02 20:43:30 localhost.localdomain NetworkManager[1038]: <info>  [1483386210.0776] manager: (ppp0): new Generic device (/org/freedesktop/NetworkManager/Devices/13)
Jan 02 20:43:30 localhost.localdomain pptp[7808]: nm-pptp-service-7786 log[main:pptp.c:356]: The synchronous pptp option is NOT activated
Jan 02 20:43:30 localhost.localdomain pptp[7818]: nm-pptp-service-7786 log[ctrlp_rep:pptp_ctrl.c:259]: Sent control packet type is 1 'Start-Control-Connection-Request'
Jan 02 20:43:30 localhost.localdomain pptp[7818]: nm-pptp-service-7786 log ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-01-03 14:09:45 -0600

drdec gravatar image

Have you opened your firewall to traffic using the GRE protocol?

Try this:

sudo firewall-cmd --add-protocol=gre
sudo firewall-cmd --query-protocol=gre

And then see if that makes a difference. If it does, make the changes permanent:

sudo firewall-cmd --permanent --add-protocol=gre
sudo firewall-cmd --permanent --query-protocol=gre

Note the query-protocol commands don't actually make changes, but will tell you if the GRE protocol has been added to the firewall.

edit flag offensive delete link more

Comments

No, I haven't.

And now that I have done, it works.

Thank you man!

Morrow1501 gravatar imageMorrow1501 ( 2017-01-04 00:08:46 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2017-01-02 13:55:20 -0600

Seen: 917 times

Last updated: Jan 03 '17