Onscreen/virtual keyboard in Kde on F25 - how to install

asked 2016-12-23 14:33:08 -0600

andrewrembrandt gravatar image

Hi, despite numerous attempts for googling the answer, I'm a little stumped on this one. I have a default Fedora 25 install, with KDE installed (using dnf install @kde-desktop) and am unable to install or enable the default KDE virtual keyboard (somewhat important as this is running on my Surface Pro 3 tablet PC).

The latest official qt5-qtvirtualkeyboard rpm referenced an older version of qt5-base, which I modified to be compatible with the current version (Requires: qt5-qtbase(x86-64) >= 5.7.0), but that doesn't seem to provide anything of use (this was a quick hacky test).

Still running GDM for login (might that be the issue?)

Any suggestions on how to get the default KDE virtual keyboard working in F25 would be much appreciated. (NB, am aware of onboard, CellWriter, eekboard, kvkbd etc - am after the default KDE virtual keyboard only)

Many thanks, Andrew

edit retag flag offensive close merge delete

Comments

Have you made any progress with this? It appears that for KDE's nicely-integrated onscreen keyboard you must be running Wayland: https://blog.martin-graesslin.com/blo... Unfortunately, while Wayland is default on the default Gnome version of Fedora, KDE still uses Xorg by default. You could try installing the package plasma-workspace-wayland but if everything blows up, I can't be held responsible! Having just recovered from a half-botched F24-25 upgrade, I am not brave enough to try that package today. If you do, let me know!

Sompom gravatar imageSompom ( 2017-01-30 18:59:52 -0600 )edit