Ask Your Question
0

Steam not running.

asked 2016-12-19 09:43:04 -0500

Linux_gamer gravatar image

I have fedora 25, if I run it it print : Running Steam on fedora 25 64-bit STEAM_RUNTIME is enabled automatically Error: You are missing the following 32-bit libraries, and Steam may not run: libc.so.6

I use: https://linuxconfig.org/installing-st...

and Exec=env LDPRELOAD='/usr/$LIB/libstdc++.so.6 /usr/$LIB/libgccs.so.1 /usr/$LIB/libxcb.so.1 /usr/$LIB/libgpg-error.so' /usr/bin/steam %U

and

rm ~/.steam/steam/ubuntu1232/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6 ~/.steam/steam/ubuntu1232/steam-runtime/i386/lib/i386-linux-gnu/libgccs.so.1 ~/.steam/steam/ubuntu1232/steam-runtime/amd64/lib/x8664-linux-gnu/libgccs.so.1 ~/.steam/steam/ubuntu1232/steam-runtime/amd64/usr/lib/x8664-linux-gnu/libstdc++.so.6 ~/.steam/steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libxcb.so.1

and nothing: Running Steam on fedora 25 64-bit STEAM_RUNTIME is enabled automatically Error: You are missing the following 32-bit libraries, and Steam may not run: libc.so.6

Help!!!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-01-21 14:19:26 -0500

gralco gravatar image

Try running STEAM_RUNTIME_PREFER_HOST_LIBRARIES=0 steam, if this works then you can modify your shortcut accordingly.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2016-12-19 09:43:04 -0500

Seen: 501 times

Last updated: Dec 19 '16