Ask Your Question
0

Touchpad scrolling not working in Fedora 25

asked 2016-12-18 08:04:43 -0500

Moin gravatar image

Hi, I updated Fedora 24 to Fedora 25 today and am not able to use touchpad scrolling now. I tried to use dconf editor to set org.gnome.desktop.peripherals.touchpad edge-scrolling-enabled to true but it did not change and gave the following error:

(dconf-editor:4041): dconf-WARNING **: failed to commit changes to dconf: The connection is closed

On doing some search, I found this bug report which mentions that if a touchpad supports two finger scrolling, there is no way to enable edge scrolling. However, my touchpad does not support 2 finger scrolling and yet I am unable to use edge scrolling. Even libinput correctly detects edge-scrolling as the only scrolling method:

Device:           AlpsPS/2 ALPS GlidePoint
Kernel:           /dev/input/event5
Group:            9
Seat:             seat0, default
Size:             73.07x51.13mm
Capabilities:     pointer 
Tap-to-click:     disabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: enabled
Calibration:      n/a
Scroll methods:   *edge 
Click methods:    none
Disable-w-typing: enabled
Accel profiles:   none
Rotation:         n/a

Any ideas on how to fix this?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-12-18 18:34:28 -0500

sergiomb gravatar image

In general we have new libinput driver and ALPS DualPoint TouchPad works well with old synaptics driver. See the answare to my question how we can disable libinput and enable synaptics drives https://lists.x.org/archives/xorg/201...

also lots of answers here : https://ask.fedoraproject.org/en/ques...

edit flag offensive delete link more

Comments

I checked the link on how to enable synaptics driver but the file /etc/X11/xorg.conf.d/99-force-synaptics.conf.disabled does not exist in my system. Infact there was only one file in that folder - 00-keyboard.conf. I tried creating it but it did not work. I think its because Fedora 25 uses Wayland instead of Xorg. The answers to the other question that you mentioned also seem to be Xorg specific. Infact, Martin mentions there "Under Xorg, you can configure all libinput options through xinput command. Under Wayland, there is no such way."

Moin gravatar imageMoin ( 2016-12-18 23:36:57 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-12-18 08:04:43 -0500

Seen: 1,294 times

Last updated: Dec 18 '16