Ask Your Question
5

xrandr doesn't work in WAYLAND, how to configure display resolution?

asked 2016-12-11 01:31:17 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I have recently installed (fresh) Fedora 25 and while trying to configure xrandr with the below command, it displays error:

command:

xrandr --output WAYLAND0 --mode "1600x900_60.00"

error:

Configure crtc 0 failed

When I tried to perform the same in Gnome on Xorg, it worked.

Please help me configuring the monitor in Wayland.

edit retag flag offensive close merge delete

Comments

1

xrandr is for Xorg, hence why it's got x at the start of its name, so that's hardly surprising. I'm afraid I don't know the solution though.

Brenton Horne gravatar imageBrenton Horne ( 2016-12-11 03:43:08 -0500 )edit

You can't use the Displays option in the Gnome control center?

ssieb gravatar imagessieb ( 2016-12-12 17:50:02 -0500 )edit

Nope. It doesn't recognise the actual resolution for monitor. It only has two basic resolutions.

Bhs gravatar imageBhs ( 2016-12-12 21:25:35 -0500 )edit

Then wayland is not recognizing your video card or your monitor properly. I would suggest filing a bug on wayland and using the Xorg option for now.

ssieb gravatar imagessieb ( 2016-12-16 15:05:46 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2016-12-11 05:28:25 -0500

hhlp gravatar image

updated 2016-12-11 05:30:47 -0500

This is well explained in this fedora wiki :

  1. How_to_debug_Wayland_problems

special this item :

  1. Many_well-known_X11_utilities_don't_work

Regards.,

edit flag offensive delete link more

Comments

1

Yes, but they only state that these are the issues which are yet to be addressed. So I believe I have to wait for the updates, that's it? Or is there a workaround?!! Any suggestion for some ready alternative to xrandr?

Bhs gravatar imageBhs ( 2016-12-11 10:35:22 -0500 )edit
0

answered 2017-07-22 23:14:56 -0500

I had just resoved this issue. Fist, you need for disable WAYLAND by uncomment in file: /etc/gdm/custom.conf

#WaylandEnable=false

Reboot your linux.

After that, run the xrandr command you will not found WAYLAND0, you will found real card: DP1, HDMI1, VGA1, etc... instead

Now, you can use xrandr to change display resolution normally (follow the guide at here: https://wiki.archlinux.org/index.php/xrandr)

edit flag offensive delete link more

Comments

This does not really address the question. Also even if gdm uses wayland, it should be possible to start an usual X.org based desktop session which is mentioned in the question.

muep gravatar imagemuep ( 2017-07-23 01:38:27 -0500 )edit

But for the Newbie (about me), I can't find any useful way to resolve this issue. I don't understand about "how to WAYLAND work". How to use wayland with correct resolution @muep?

caochitam gravatar imagecaochitam ( 2017-07-24 02:46:55 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-12-11 01:31:17 -0500

Seen: 14,815 times

Last updated: Jul 22 '17