Ask Your Question
4

Fedora 25: Headphones are not working

asked 2016-12-10 22:07:13 -0500

augstya gravatar image

updated 2017-03-04 04:36:54 -0500

deadrat gravatar image

Fedora 25, The speakers are working fine. But the wired headphones are not working. Tried many changes in modprobe with sndhdaintel model to auto, generic etc, index, position_fix etc.. But none of them are working.

Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)

The following is the bug report: Please Suggest

upload=true&script=true&cardinfo=
!!################################
!!ALSA Information Script v 0.4.64
!!################################

!!Script ran on: Tue Dec 13 17:11:40 UTC 2016


!!Linux Distribution
!!------------------

Fedora release 25 (Twenty Five) NAME=Fedora ID=fedora PRETTY_NAME="Fedora 25 (Workstation Edition)" CPE_NAME="cpe:/o:fedoraproject:fedora:25" HOME_URL="https://fedoraproject.org/" BUG_REPORT_URL="https://bugzilla.redhat.com/" REDHAT_BUGZILLA_PRODUCT="Fedora" REDHAT_BUGZILLA_PRODUCT_VERSION=25 REDHAT_SUPPORT_PRODUCT="Fedora" REDHAT_SUPPORT_PRODUCT_VERSION=25 PRIVACY_POLICY_URL=https://fedoraproject.org/wiki/Legal:PrivacyPolicy Fedora release 25 (Twenty Five) Fedora release 25 (Twenty Five)


!!DMI Information
!!---------------

Manufacturer:      ASUSTeK COMPUTER INC.
Product Name:      K55A
Product Version:   1.0       
Firmware Version:  K55A.407


!!Kernel Information
!!------------------

Kernel release:    4.8.12-300.fc25.x86_64
Operating System:  GNU/Linux
Architecture:      x86_64
Processor:         x86_64
SMP Enabled:       Yes


!!ALSA Version
!!------------

Driver version:     k4.8.12-300.fc25.x86_64
Library version:    
Utilities version:  1.1.1


!!Loaded ALSA modules
!!-------------------

snd_hda_intel


!!Sound Servers on this system
!!----------------------------

Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes

Jack:
      Installed - Yes (/usr/bin/jackd)
      Running - No


!!Soundcards recognised by ALSA
!!-----------------------------

 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7e10000 irq 30


!!PCI Soundcards installed in the system
!!--------------------------------------

00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)


!!Advanced information - PCI Vendor/Device/Subsystem ID's
!!-------------------------------------------------------

00:1b.0 0403: 8086:1e20 (rev 04)
    Subsystem: 1043:1457


!!Modprobe options (Sound related)
!!--------------------------------

snd_hda_intel: model=eapd probe_mask=1 position_fix=1


!!Loaded sound module options
!!---------------------------

!!Module: snd_hda_intel
    align_buffer_size : -1
    bdl_pos_adj : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
    beep_mode : N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N,N
    enable : Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y
    enable_msi : -1
    id : (null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)
    index : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
    jackpoll_ms : 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
    model : eapd,(null),(null ...
(more)
edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
2

answered 2016-12-11 03:35:04 -0500

jmarinho gravatar image

updated 2017-12-27 11:59:32 -0500

Hi.

I normally face the same problem in any Linux distribution. I connect the speakers to the back audio jack and when I connect the headphones to the front pannel audio jack they doesn't work or work simultaneosly with the headphones. My audio device is not the same than yours:

Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05).

The fix I've found to my problem is to create (or change if it exists yet) a file in /etc/modprobe.d/ named alsa-base.conf

Try this:

sudo mv /etc/modprobe.d/alsa-base.conf /etc/modprobe.d/alsa-base.conf.old
sudo sh -c 'echo "options snd-hda-intel model=generic
options snd-hda-intel index=1" >> /etc/modprobe.d/alsa-base.conf'

Reboot your computer

What I did here is to backup your configuration and create a new file (/etc/modprobe.d/alsa-base.conf) with this content:

options snd-hda-intel model=generic
options snd-hda-intel index="1"

This usually works for me in any Linux distribution Ubuntu, Debian... and now is working on Fedora 25: when I connect the headphones the speakers mute and I hear the sound on the headphones. When I was investigating the issue I discover that I is related with a control in alsamixer (auto-mute mode) that it's not enabled by default when I install a Linux distribution, but when I set the file in that way, it works.

Hope this helps.

Sorry for my english and for not being able to give a more technnical explanation. I'm still learning and new on Fedora

edit flag offensive delete link more

Comments

Hello, Thank you for taking time to post the suggestion. I tried to do what you said. There was no "alsa-base.conf" in the location provided or the in the system. I went ahead and created one. Yet, it isn't working.

augstya gravatar imageaugstya ( 2016-12-11 10:33:56 -0500 )edit
1

Is your computer a laptop? If it is, you could try add this content to alsa-base.conf:

options snd-hda-intel model=laptop

This solution works for a person that reports this bug on Launchpad and in the comments someone suggest him this solution and it works..

If not try to investigate on Internet what configuration you should set on /etc/modprobe.d/alsa-base.conf for a sound card with the codec alc270. Good luck!

jmarinho gravatar imagejmarinho ( 2016-12-12 10:01:37 -0500 )edit

Hi, one point about your suggested fixes — this:

sudo echo "options snd-hda-intel model=generic
options snd-hda-intel index=1" >> /etc/modprobe.d/alsa-base.conf

will never work, as the output redirection occurs in your user shell (outside of sudo), so it won't have permission to write (append) to /etc/modprobe.d/alsa-base.conf. To do output redirection in a sudo command you have to launch the whole command inside a root shell, like so:

sudo sh -c 'echo "options snd-hda-intel model=generic
options snd-hda-intel index=1" >> /etc/modprobe.d/ala-base.conf'
FeRDNYC gravatar imageFeRDNYC ( 2016-12-25 09:44:01 -0500 )edit

The other option is to use tee -a (for --append), which avoids running the echo as root:

echo "options snd-hda-intel model=generic
options snd-hda-intel index=1" | sudo tee -a /etc/modprobe.d/alsa-base.conf
FeRDNYC gravatar imageFeRDNYC ( 2016-12-26 06:37:38 -0500 )edit

Hey FeRDNYC, Thanks for your suggestion. I tried what you said. It worked a while and again it stopped. No Same Situation again!

augstya gravatar imageaugstya ( 2016-12-28 13:34:58 -0500 )edit
0

answered 2017-06-26 23:15:08 -0500

P4T0U gravatar image

updated 2017-07-01 16:15:24 -0500

Hi,

Seems like I had the same problem but with a Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04) (8086:1e20).

I managed to get mine working by using the following commands:

sudo dnf remove pulseaudio
reboot
sudo dnf install control-center gdm gnome-bluetooth gnome-bluetooth-libs gnome-classic-session gnome-initial-setup gnome-keyring-pam gnome-session-xsession gnome-shell gnome-shell-extension-alternate-tab gnome-shell-extension-apps-menu gnome-shell-extension-background-logo gnome-shell-extension-common gnome-shell-extension-launch-new-instance gnome-shell-extension-places-menu gnome-shell-extension-window-list libgnomekbd mutter nm-connection-editor pulseaudio pulseaudio-gdm-hooks pulseaudio-module-bluetooth rtkit sbc soxr speexdsp telepathy-filesystem telepathy-logger vino
startx

Although it didn't tell me what was exactly my problem, it did greatly help in critical situations.

More info (alsa-info):

!!################################
!!ALSA Information Script v 0.4.64
!!################################

!!Script ran on: Tue Jun 27 02:27:59 UTC 2017


!!Linux Distribution
!!------------------

Fedora release 25 (Twenty Five) NAME=Fedora ID=fedora PRETTY_NAME="Fedora 25 (Workstation Edition)" CPE_NAME="cpe:/o:fedoraproject:fedora:25" HOME_URL="https://fedoraproject.org/" SUPPORT_URL="https://fedoraproject.org/wiki/Communicating_and_getting_help" BUG_REPORT_URL="https://bugzilla.redhat.com/" REDHAT_BUGZILLA_PRODUCT="Fedora" REDHAT_BUGZILLA_PRODUCT_VERSION=25 REDHAT_SUPPORT_PRODUCT="Fedora" REDHAT_SUPPORT_PRODUCT_VERSION=25 PRIVACY_POLICY_URL=https://fedoraproject.org/wiki/Legal:PrivacyPolicy Fedora release 25 (Twenty Five) Fedora release 25 (Twenty Five)


!!DMI Information
!!---------------

Manufacturer:      ASUSTeK COMPUTER INC.
Product Name:      K55A
Product Version:   1.0       
Firmware Version:  K55A.406
Board Vendor:      ASUSTeK COMPUTER INC.
Board Name:        K55A


!!ACPI Device Status Information
!!---------------

/sys/bus/acpi/devices/ATK3001:00/status      15
/sys/bus/acpi/devices/ATK4001:00/status      15
/sys/bus/acpi/devices/ETD0108:00/status      15
/sys/bus/acpi/devices/INT3F0D:00/status      15
/sys/bus/acpi/devices/PNP0103:00/status      15
/sys/bus/acpi/devices/PNP0C01:00/status      15
/sys/bus/acpi/devices/PNP0C01:01/status      15
/sys/bus/acpi/devices/PNP0C0A:00/status      31
/sys/bus/acpi/devices/PNP0C0F:00/status      9
/sys/bus/acpi/devices/PNP0C0F:01/status      9
/sys/bus/acpi/devices/PNP0C0F:02/status      9
/sys/bus/acpi/devices/PNP0C0F:03/status      9
/sys/bus/acpi/devices/PNP0C0F:04/status      9
/sys/bus/acpi/devices/PNP0C0F:05/status      9
/sys/bus/acpi/devices/PNP0C0F:06/status      9
/sys/bus/acpi/devices/PNP0C0F:07/status      9


!!Kernel Information
!!------------------

Kernel release:    4.11.6-201.fc25.x86_64
Operating System:  GNU/Linux
Architecture:      x86_64
Processor:         x86_64
SMP Enabled:       Yes


!!ALSA Version
!!------------

Driver version:     k4.11.6-201.fc25.x86_64
Library version:    
Utilities version:  1.1.1


!!Loaded ALSA modules
!!-------------------

snd_hda_intel


!!Sound Servers on this system
!!----------------------------

Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes


!!Soundcards recognised by ALSA
!!-----------------------------

 1 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7e10000 irq 30


!!PCI Soundcards installed in the system
!!--------------------------------------

00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)


!!Advanced information - PCI Vendor/Device/Subsystem ID's
!!-------------------------------------------------------

00:1b.0 0403: 8086:1e20 (rev 04)
    Subsystem: 1043:1457


!!Modprobe options (Sound related)
!!--------------------------------

snd_hda_intel: model=laptop-amic
snd_hda_intel: index=1
snd_hda_intel: model=laptop-amic


!!Loaded sound module options
!!---------------------------

!!Module: snd_hda_intel
    align_buffer_size : -1
    bdl_pos_adj : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1 ...
(more)
edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2016-12-10 22:07:13 -0500

Seen: 5,901 times

Last updated: Dec 27 '17