Ask Your Question
0

How to edit touchpad settings in Fedora 25 ?

asked 2016-12-10 17:50:16 -0600

Patrik gravatar image

In my Lenovo T560, all the drivers work fine with Fedora 25, but I can not see the TouchPad section in All Settings > Mouse & Touchpad.

image description

My laptop's touchpad works with Fedora 25. Two-fingers scroll and pinch-to-zoom work. But the tap-to-click does not work, and I can not access the touchpad settings to enable this feature.

According to gnome help, when you open All Settings > Mouse & Touchpad, the "The Touchpad section only appears if your system has a touchpad."

Could anybody give me a suggestion on to fix my touchpad?

edit retag flag offensive close merge delete

Comments

check your Xorg.log (journalctl _COMM=gdm-x-session) for what driver is used by the touchpad. Most likely it's the legacy xorg-x11-drv-synaptics driver instead of libinput. In that case, just remove xorg-x11-drv-synaptics and install xorg-x11-drv-libinput (if it isn't yet) and things should work.

If you have any custom /etc/X11/xorg.conf.d snippets that have a Driver "synaptics" line, then you should remove those too.

whot gravatar imagewhot ( 2016-12-13 16:28:41 -0600 )edit

Did you try scrolling down the window? There are more options below? (see the dotted line - - - - - - )

alfC gravatar imagealfC ( 2017-01-05 04:45:57 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2016-12-10 20:50:24 -0600

florian gravatar image

updated 2016-12-10 21:12:56 -0600

You can use the following command to enable tap-to-click

gsettings set org.gnome.desktop.peripherals.touchpad tap-to-click true
edit flag offensive delete link more

Comments

florian gravatar imageflorian ( 2016-12-10 21:14:37 -0600 )edit

This worked for me... Thanks

madgoks gravatar imagemadgoks ( 2016-12-24 03:19:11 -0600 )edit
1

answered 2017-01-04 18:01:28 -0600

happymaster23 gravatar image

updated 2017-01-04 18:02:21 -0600

I discovered, that problem is quite simple. Touchpad setting is not missing, but you have to scroll down in settings window to see it...

edit flag offensive delete link more
0

answered 2016-12-10 19:23:41 -0600

Patrik gravatar image

Update: I managed to make the tap-to-click work, and this fixes my main use case.

To enable the tap-to click, when the touchpad tab is not visible:

  1. launch dconf-editor
  2. select org/gnome/desktop/peripherials/touchpad/tap-to-click
  3. enable tap-to-click, as you see in the image below

image description

Note: I'm still not able to see touchpad settings, but my main use case is solved.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-12-10 17:50:16 -0600

Seen: 7,341 times

Last updated: Jan 04 '17