Ask Your Question
0

Dependencies issues F23 Digikam

asked 2016-12-10 09:43:07 -0500

edwardc01 gravatar image

I have the following error when trying to update F23.

Error: package digikam-libs-4.14.0-7.fc23.x86_64 requires liblensfun.so.0()(64bit), but none of the providers can be installed (try to add '--allowerasing' to command line to replace conflicting packages)

How do I get liblensfun.so.0()(64bit) added to the updates repository?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-12-10 09:56:32 -0500

sergiomb gravatar image

updated 2016-12-20 06:59:19 -0500

we are fixing this more details on https://bugzilla.redhat.com/show_bug....

F24 don't have bronken deps, but if you go upgrade to F24 , you shouldn't update F23 before, in general , we want avoid have a versions that are bigger in previous Fedora version , so if you not update F23 you got better chances. About this case I think doesn't matter because packages are compatible with F24 versions .

Anyway I think it will be all updated before F23 EOL, digikam , ufraw and rawstudio was already pushed to updates stable , now is an mirror question .

edit flag offensive delete link more

Comments

Thanks, that's my final update to get to F24.

edwardc01 gravatar imageedwardc01 ( 2016-12-10 11:31:35 -0500 )edit

One more day till EOL on F23 and still have broken dependencies:

  • digikam x86_64 4.14.0-8.fc23 updates 10 M
  • digikam-doc noarch 4.14.0-8.fc23 updates 19 M
  • digikam-libs x86_64 4.14.0-8.fc23 updates 2.4 M
  • lensfun x86_64 0.3.2-2.fc23 updates 246 k

Will I be able to update to F24 with these broken dependencies?

edwardc01 gravatar imageedwardc01 ( 2016-12-19 10:09:42 -0500 )edit

Well it's now 12/22 and still not able to update without broken dependencies. Still getting the dependencies issues as mentioned above. With the --best option to dnf it shows: "package darktable-1.6.9-6.fc23.x86_64 requires liblensfun.so.0()(64bit), but none of the providers can be installed".

It appears you think all dependencies issues have been resolved and it is a matter of them making it to the mirrors for me to get updated.

How long to update the mirrors?

edwardc01 gravatar imageedwardc01 ( 2016-12-22 10:22:29 -0500 )edit

I believe the problem is that darktable and digikam are built to use different versions of lensfun. I removed darktable and vlc, did dnf clean all, and then ran dnf upgrade --refresh. It ran with no broken dependencies. It istalled qt-mysql and upgraded digikam, digikam-docs, digikam-libs and lensfun 0.3.2-2. I then installed vlc but had to do it with --allowerasing and it ran good. I then ran dnf install darktable with --allowerasing option and it installed darktable but downgraded lensfun to 0.3.1-1 and digikam to 4.13.0-1. Then when dnf upgrade is run I/m back to the same broken dependen

edwardc01 gravatar imageedwardc01 ( 2016-12-23 16:19:07 -0500 )edit

Either the above or you can't have both digikam and darktable on the same system.

edwardc01 gravatar imageedwardc01 ( 2016-12-23 16:20:05 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-12-10 09:43:07 -0500

Seen: 99 times

Last updated: Dec 20 '16