How to rotate display under Wayland?

asked 2016-12-06 15:49:45 -0600

updated 2016-12-06 16:10:45 -0600

When I moved my laptop I accidentally must have pressed something that rotated my display (under GNOME 3.22 on Wayland) by 90 degrees. How do I rotate it back? I have gone to display (in settings) but it doesn't have a rotate option, only options related to screen resolution. image description

edit retag flag offensive close merge delete

Comments

1

Go to configuration -> screen when you see your screen doble click on it you should get a screen with the rotate controls on it.

aeperezt gravatar imageaeperezt ( 2016-12-06 22:08:28 -0600 )edit

Are you using wayland? I had my screen rotate on me and couldn't find any way to rotate it back. I had to move my laptop around until it got to the right orientation and then hit the lock button. Double-clicking doesn't do anything in the displays control panel and there are no rotation options. In F24 using X, if you click on the monitor, there are rotation options.

ssieb gravatar imagessieb ( 2016-12-12 17:20:49 -0600 )edit

Ah you did read that I had attached the tag "fedora25" right? So this question pertains to Fedora 25, wherein the default display server protocol is Wayland, not Xorg. With Fedora 25 you have to deliberately select GNOME on Xorg (in the GDM display manager) in order to start GNOME on Xorg, as the default option is GNOME on Wayland, which is the one I was running.

Brenton Horne gravatar imageBrenton Horne ( 2016-12-12 17:25:01 -0600 )edit

Yes, I was replying to the comment before mine. Sorry, I could have been more clear about that. I had the same problem as you with no solution. I can't edit the comment now to clarify that...

ssieb gravatar imagessieb ( 2016-12-12 17:53:31 -0600 )edit