Ask Your Question
0

Since Saturday I'm receiving broken dependencies on 9 packages when trying to update Fedora 23

asked 2016-12-06 12:19:29 -0600

edwardc01 gravatar image

updated 2016-12-06 15:17:18 -0600

florian gravatar image

I'm receiving "Skipping packages with broken dependencies:" for the following 9 packages:

 ffmpeg           x86_64    1:3.2.1-1.fc23            fedora-HandBrake    1.5 M
 ffmpeg-libs      x86_64    1:3.2.1-1.fc23            fedora-HandBrake    6.2 M
 lensfun          x86_64    0.3.2-2.fc23              updates             246 k
 libavdevice      x86_64    1:3.2.1-1.fc23            fedora-HandBrake     65 k
 live555-libs     x86_64    1:2016.11.06-2.fc23       fedora-HandBrake    368 k
 openh264-libs    x86_64    1:1.6.0-2.fc23            fedora-HandBrake    362 k
 vlc              x86_64    1:2.2.4-3.fc23            fedora-HandBrake    1.5 M
 vlc-core         x86_64    1:2.2.4-3.fc23            fedora-HandBrake    9.0 M
 vlc-extras       x86_64    1:2.2.4-3.fc23            fedora-HandBrake     33 k

How do I report to someone who can fix?

edit retag flag offensive close merge delete

Comments

use --best option in dnf , will say what are the broken deps

sergiomb gravatar imagesergiomb ( 2016-12-07 10:36:20 -0600 )edit

I did as you suggested and the output I got is as follows: Error: package gstreamer1-plugins-bad-1:1.6.4-3.fc23.x86_64 requires libopenh264.so.1()(64bit), but none of the providers can be installed. package kf5-kdeclarative-5.27.0-1.fc23.x86_64 requires qt5-qtbase(x86-64) = 5.6.1, but none of the providers can be installed. package digikam-libs-4.14.0-7.fc23.x86_64 requires liblensfun.so.0()(64bit), but none of the providers can be installed. package kf5-kdeclarative-5.27.0-1.fc23.x86_64 requires qt5-qtbase(x86-64) = 5.6.1, but none of the providers can be installed. continued

edwardc01 gravatar imageedwardc01 ( 2016-12-07 13:19:29 -0600 )edit

package kf5-kdeclarative-5.27.0-1.fc23.x86_64 requires qt5-qtbase(x86-64) = 5.6.1, but none of the providers can be installed. package gstreamer1-plugins-bad-1:1.6.4-3.fc23.x86_64 requires libopenh264.so.1()(64bit), but none of the providers can be installed (try to add '--allowerasing' to command line to replace conflicting packages) I've never used --allowerasing, Is it a safe way to resolve dependencies issues?

edwardc01 gravatar imageedwardc01 ( 2016-12-07 13:22:08 -0600 )edit

you may try and see the result and after decide to install it or not

sergiomb gravatar imagesergiomb ( 2016-12-07 17:03:53 -0600 )edit

I have the same problem. Eventually, they cleaned up and now I have only the three lensfun packages broken, due to ufraw, ufraw-gimp, and gimp-lensfun.

Luis Florit gravatar imageLuis Florit ( 2016-12-15 11:33:55 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-12-09 08:52:57 -0600

edwardc01 gravatar image

Well today the original 9 packages shown above were listed to be updated and did update fine. Don't know what the problem was. However that leaves 32 packages from Fedora Update that won't update. The dependencies shown with --best are: Error: package kf5-kdeclarative-5.27.0-1.fc23.x86_64 requires qt5-qtbase(x86-64) = 5.6.1, but none of the providers can be installed. package digikam-libs-4.14.0-7.fc23.x86_64 requires liblensfun.so.0()(64bit), but none of the providers can be installed. package kf5-kdeclarative-5.27.0-1.fc23.x86_64 requires qt5-qtbase(x86-64) = 5.6.1, but none of the providers can be installed (try to add '--allowerasing' to command line to replace conflicting packages)

They may eventually get fixed, apparently none of this was of my making.

edit flag offensive delete link more
1

answered 2016-12-06 15:10:41 -0600

geforce gravatar image

updated 2016-12-07 02:27:57 -0600

Complain to negativo repo if you can find somewhere to do that.

http://negativo17.org/handbrake/

You could fix it using distro-sync, it will remove all the packages from the conflicting repo

sudo rm /etc/yum.repos.d/fedora-handbrake.repo
sudo dnf distro-sync
edit flag offensive delete link more

Comments

Since the original post the list of packages with broken dependencies has grown to 42 packages. If I follow the above advice it seems that I might have a broken system since the list has grown so much. I don't mind removing the repo but is there another way to get VLC, HandBrake, and MakeMKV? I use VLC a lot and the use of HandBrake and MakeMKV is sporadic. It seems dangerous to leave the system with so many updates pending since I don't know if any are security related or just feature updates. Also it would appear that these applications need to be flatpack apps.

edwardc01 gravatar imageedwardc01 ( 2016-12-07 08:45:32 -0600 )edit

I did post the problem to https://handbrake.fr/report.php#view4 . Will have to wait to see if I get a response.

edwardc01 gravatar imageedwardc01 ( 2016-12-07 08:46:06 -0600 )edit

Get VLC from rpmfusion.

florian gravatar imageflorian ( 2016-12-07 09:57:30 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2016-12-06 12:19:29 -0600

Seen: 276 times

Last updated: Dec 09 '16