Ask Your Question

problem with install programs

asked 2016-12-04 11:43:32 -0600

majd0z gravatar image

hi i have problem with fedora 25 when i want update or install programs like kodi vlc ... its start downloading and after finish it says input

 sudo dnf install ffmpegthumbnailer.i686 -y

outout Total 13 kB/s | 34 MB 43:32
warning: /var/cache/dnf/rpmfusion-free-a7bfe045b42454ed/packages/ffmpegthumbnailer-2.1.2-1.fc25.i686.rpm: Header V4 RSA/SHA1 Signature, key ID 6806a9cb: NOKEY Importing GPG key 0xB7546F06: Userid : "RPM Fusion free repository for Fedora (24)" Fingerprint: 55E7 903B 6087 98E4 EC78 64CD 9F63 8721 B754 6F06 From : /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-25 Key imported successfully Import of key(s) didn't help, wrong key(s)? The downloaded packages were saved in cache until the next successful transaction. You can remove cached packages by executing 'dnf clean packages'. Error:

Public key for ffmpegthumbnailer-2.1.2-1.fc25.i686.rpm is not installedFailing package is: ffmpegthumbnailer-2.1.2-1.fc25.i686 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-25

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2016-12-04 17:02:52 -0600

lovepump gravatar image

updated 2016-12-04 19:00:56 -0600

With rpmfusion repo since fedora25 came out I have been having to use "--nogpgcheck" switch with yum. When I do any sort of subsequent "dnf update" with the rpmfusion repo "enabled" it pukes out with this same error. So what I've been doing is enable rpmfusion temporarily, run with --no-gpg-check, and then disable the repo again so dnf works afterward. Potentially, the repo entries in /etc/yum.repos.d/<rpmfusion> can be changed so that gpgcheck=1 is gpgcheck=0 and that might work as a "permanent but probably bad workaround"

Pretty sure this isn't a "fedora" problem, it is an "rpmfusion" problem.

EDIT: I've just been able to run "dnf update" with the newest rpmfusion repos installed (using the rpmfusion rpms to add them). I first had to make sure the rpms weren't "installed":

sudo rpm -e rpmfusion-free-updates
sudo rpm -e rpmfusion-nonfree-updates

and then I had to "get rid" of the old gpg keys from the fedora24 versions in /etc/pki/rpm-gpg, ala:

sudo mv /etc/pki/rpm-gpg/*rpmfusion* /someotherplace

and then

sudo rpm -Uvh$(rpm -E %fedora).noarch.rpm 
sudo rpm -Uvh$(rpm -E %fedora).noarch.rpm
edit flag offensive delete link more

Question Tools


Asked: 2016-12-04 11:43:32 -0600

Seen: 246 times

Last updated: Dec 04 '16