Ask Your Question

Installing proprietary Nvidia drivers on Dell Inspiron 7559

asked 2016-12-04 03:28:33 -0600

Juozas gravatar image


I have Dell Inspiron 7559 notebook equipped with Nvidia GeForce GTX 960M and integrated Intel graphics. Has anybody had any luck installing proprietary Nvidia on this? Fedora 25 won't even boot unless I disable nouveau in Grub bootloader. It seems that nouveau can't mediate between the two graphic modes.

I've already unsuccessfully tried bumblebee. Installaton using guide also resulted in failure.

Any ideas? Thanks!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2016-12-04 05:19:53 -0600

thingummybob gravatar image

I'm still learning too and certainly no expert (feel free to correct), but I recently resolved my woes when using supported Nvidia drivers by reverting my Nvidia install at "if-not-true-*", using their instructions to uninstall, hereby getting back to basics. Note that you will need to remove the line "exclude -x11" otherwise the libraries won't download. I then used the installation from rpmfusion as it seems they're on top of the packaging etc. They have clear instructions on their page:


But note: you need to ensure you've removed any other 'corrupting' packages first. If for example you'd been using the negativo17 repo, his compiled packages use versions of e.g dkms that conflict. I resolved this by using the install line from rpmfusion with

--best --allowerasing

something like this should do it. This includes the 32bit libs, just in case you're running Steam etc:

# dnf install --best --allowerasing dnf install xorg-x11-drv-nvidia xorg-x11-drv-nvidia-libs.i686 akmod-nvidia "kernel-devel-uname-r == $(uname -r)"
edit flag offensive delete link more

answered 2017-01-21 13:31:42 -0600

I am using this laptop now with just nouveau, it works, but you have to do it in a very specific way.

Disable Secure Boot in bios Keep UEFI enabled

Hit F12 on boot and select the UEFI USB flash drive go to troubleshooting section and select boot from basic graphics mode

The real painful part is the mouse wont work, you have to use the tab key to select continue, and any options.. and to make it a little worse, once you select your keyboard mode and hit continue it sits there for 3-5 minutes before it will go to the next screen.

edit flag offensive delete link more

Question Tools



Asked: 2016-12-04 03:28:06 -0600

Seen: 652 times

Last updated: Jan 21 '17