Ask Your Question
0

Yet another "No sound in Fedora 16"

asked 2011-11-17 16:36:54 -0600

Marc_Boisvert gravatar image

As you can read in the title, I have (and many others) a problem with sound in Fedora 16. I am using a dual monitor setup, of which one of my display is actually a TV and is connected via HDMI. My other display is a regular monitor wit no sound output option and is connected via DVI.

As you can imagine, I want sound to come out of my TV.

My graphics card is an ATI Radeon HD5850.

One of the "possible" solution was to install the propriatery drivers from ATI (Catalyst) but that resulted in poor performance in the system. Sound was working though.

So I have been sniffing around and googling but I haven't found a solution yet.

edit retag flag offensive close merge delete

9 Answers

Sort by ยป oldest newest most voted
1

answered 2011-11-18 10:10:46 -0600

kernelk gravatar image

mmm why not try "Fedora Utils"? this script install correctly all drivers, http://fedorautils.sourceforge.net/

edit flag offensive delete link more
1

answered 2011-11-18 01:18:57 -0600

mether gravatar image

Search in bugzilla for existing reports and do file a new one if necessary.

edit flag offensive delete link more
1

answered 2011-11-18 08:35:59 -0600

ritz gravatar image

Not very sure, but open up sound setting from gnome control center and select Hardware page, and change the Profile to HDMI output from drop down list.

If this fails, we lack the h/w support. Please file a bug report and cross your fingers and hope devs have access to this h/w .

edit flag offensive delete link more
0

answered 2012-07-30 17:23:02 -0600

daemondave gravatar image

updated 2013-01-05 10:52:04 -0600

hhlp gravatar image

I tried all the suggestions, yum installed lots of clag and still no joy: then I just looked at permissions. I found a ACL flaw with Fedora 16. If you use command getfacl on the sound devices inside /dev you might see permissions are set to root only like this:

 [root@dogma ~]# getfacl /dev/snd/pcmC0D0c
getfacl: Removing leading '/' from absolute path names
# file: dev/snd/pcmC0D0c
# owner: root
# group: audio
user::rw-
group::rw-
other::---

[root@dogma ~]# chmod o+rwx -R /dev/snd
[root@dogma ~]# getfacl /dev/snd/pcmC0D0c
getfacl: Removing leading '/' from absolute path names
# file: dev/snd/pcmC0D0c
# owner: root
# group: audio
user::rw-
group::rw-
other::rwx

Once I opened all access read write execute and it worked first try. Another hint this might be the problem is if your gnome-sound setting shows a hardware device "dummy" because it couldn't get access.

Sometimes the simplest is just that.

edit flag offensive delete link more

Comments

that helps, but another question is still open: when and why are the permissions changed?

nusrat gravatar imagenusrat ( 2014-08-18 03:19:40 -0600 )edit
0

answered 2012-01-22 09:32:49 -0600

"Check the volume" excellent suggestion I was googling for an hour before I did this - oops

edit flag offensive delete link more

Comments

You should give karma to the answer that helped you, and comment below it.

randomuser gravatar imagerandomuser ( 2013-01-05 18:33:59 -0600 )edit
0

answered 2011-11-18 10:11:36 -0600

lzap gravatar image

Check the volume. Seriously, it can be turned down after installation.

edit flag offensive delete link more
0

answered 2013-01-05 11:30:09 -0600

Weatherlawyer gravatar image

The sound icon opens a panel that I must slide up or down to increase or decrease sound level. It would be an idea to have a sign telling us which way is increasing or decreasing the sound level.

Fortunately for me my sound appears to be OK. (It "pops" as I increase the volume.) I'd be lost if it didn't though.

edit flag offensive delete link more
0

answered 2012-11-21 14:42:55 -0600

fedora4life gravatar image

I solved my Fedora HDMI Sound problem on my computer.

This might help you as well. I've written a post on my blog.

just follow the link provided below.

http://cool-technology.blogspot.com/2012/11/no-sound-fedora-16-or-17-and-geforce.html

edit flag offensive delete link more
0

answered 2011-12-17 20:11:57 -0600

tonybrowning gravatar image

With the new Fedora 16 my sound was fixed through Fedora's updates after 12 days with no sound. I'm just speculating that the new package Fedora has now added allowing one's computer to become voice activated and only if activated to allow a blind person to be able to use a computer thus delaying and/or causing our sound trouble. Of which is remarkable and a great feat!!! Sometimes they just need to get the kinks out and they probably ran into trouble along the way.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2011-11-17 16:36:54 -0600

Seen: 15,292 times

Last updated: Jan 05 '13