Ask Your Question
0

How To Change Default USB Mount Read Only Settings?

asked 2016-12-03 18:24:58 -0600

cjflnyc gravatar image

Hello all, I got Fedora as it seem like the only linux to work fine with my intel fakeraid and Nvidia video combo. And trust me between both of these issues it must have taken me one week to finally find Fedora version 24 and "Only" 24 to be fully compatible with my raid and along with Nvidia GTX-650 driver installed worked without errors! I am mostly a linux newbie. I really like Ubuntu and from my experience using it very easy but I can not with this computer and I am stuck with what seems like a much more advanced operating system,

So with Fedora 24 now working perfect with all my device drivers I go to back up some documents on my USB thumb drive and Surprise read only.

So my problem I plug in ANY usb drive. This can be a USB thumb drive or an external hard drive. I can browse the content fine but I can not write to the disk. At first I thought it was a bad disk until I tried all of the ones I have! Same issue. So I did some reading, I'm not sure how accurate this is but from what I can tell. This sort of behaviour is normal default security setting with Fedora. To me this makes no logic sense at all for a more "mainstream" disto. I could see some strict default settings for distros like RHEL or Centos but Fedora? What do I know Apparently!

Anyhow some have an answer to similar questions and I see answers like "Just mount in in terminal as root" These helpful people seem to forget some of us on here asking for help are not all that familiar with even basic terminal navigation never even less know internal commands. or even better with examples like replace X with your/path/to/drive things like this I don't understand. Could someone provide a detailed guide on how to find out what your drive paths are.Or if provided with a similar answer elaborate on where to find this information to put in /put/your/info/here type of examples.

So once I can figure out some basic Terminal work for this issue it should be fine :) Is there a way to change this darn default setting to something that makes a little more sense? I see it very much as a nag and for someone like me time consuming having to go into shell every time to do a special mount ( And fail many attempts ) and have to find out where every drive maps to within the system etc, I got like 10s of drives, This will be a nightmare! Perhaps for all you linux gurus out there, its just a simple sting of text with your eyes closed. Boy do I wish I knew that much!

Anyhow just this minor issue and my Fedora system would be the ultimate. So In short I need to know how to ... (more)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2016-12-03 23:14:57 -0600

cjflnyc gravatar image

Looks like for me all I had to do was restart the system. Allow for a full system boot up with the USB drives plugged in. For some reason now full read and write. even NTFS file system. I also used Gparted to confirm the system was seeing my USB Drive and did a fresh format on the USB drives from Gparted as I read elsewhere as a recommendation. I'm sure the experts can do what I did from terminal. Gparted provided me with that "Familiar" GUI to get the job done quickly. Just putting it out here so others can see the obvious solution I failed to see right away.

edit flag offensive delete link more
0

answered 2016-12-03 21:19:58 -0600

lovepump gravatar image

updated 2016-12-03 21:42:44 -0600

Very generally (I can help more specifically if I know more):

Are the users (UIDs) and groups (GIDs) the same in "newfedora" as they were in "oldubuntu"? if not, then change ownership (sudo chown user:group files) or permissions (sudo chmod +w files)

Are the filesystem(s) on the USB drive read/write filesystems? In other words, did you copy an "ISO image" to the USB drive? ISO9660 (CD-ROM) is a read-only filesystem, you'll have to copy the files somewhere else, change the filesystem on the USBstick to one with "write" and copy them back.

Is it just "automount" somehow screwing things up? unmount (umount /dev/readonlyusbfilesystem) and mount (mount /dev/usbfilesystem /fedoramountpoint) them manually

This last little part my leave you asking, "ok, where is stuff currently automounted now so that I can manually unmount it?"

in fedora24/25 "by default automounts of removeable media" end up under:

/run/media/yourusername/

you can always find out what is currently mounted with:

sudo mount | more

Intent behind the filesystem hierarchy here: https://en.wikipedia.org/wiki/Filesys...

There is no "authority" regarding this because no one is "in charge" of "all" linux/gnu distributions.

edit flag offensive delete link more

Comments

see my "let's get your USB fixed answer below" first. However, a couple of commands that might want to become familiar with (for most, precede these with "sudo" or "be the root user"):

"mount" (shows you what is mounted) "df" (shows you mounted, and the free space. I like to use "df -h", human-readable) "fdisk -l" (that is a lower-case "L". Shows you partitions/filesystems, even on unmounted devices. I use it to tell me unknown filesystem info) "lsblk" (list "block devices")

Additionally, some files in the /etc directory are important. check "man /etc/mtab" and "/etc/fstab"

lovepump gravatar imagelovepump ( 2016-12-03 22:02:19 -0600 )edit

Question Tools

Stats

Asked: 2016-12-03 18:24:58 -0600

Seen: 3,822 times

Last updated: Dec 03 '16