Ask Your Question
1

How to define gdm login banner & disable user list in Fedora-16

asked 2011-11-15 00:39:36 -0600

bbfedora gravatar image

updated 2011-12-03 17:50:34 -0600

mether gravatar image

In Fedora-15, one could use gconf-editor as user gdm to define bannermessageenable, bannermessagetext, and disableuserlist in the /var/lib/gdm/.gconf/apps/gdm/simple-greeter/%gconf.xml file, and those definitions would be effective on the gdm-simple-greeter console login screen (new graphical.target replacement of runlevel 5 mode).

In Fedora-16, gconf-editor can be used to set up the same definitions in the same %gconf.xml file, but they have no effect on the console login screen.

How does one set up a console login banner message and disable the user list in Fedora-16? It appears that the gdm-simple-greeter is not running under Fedora-16, and that instead a process "gnome-shell --gdm-mode" might be handling the console login screen.

edit retag flag offensive close merge delete

Comments

related question -> #3515](/question/3515/)

hhlp gravatar imagehhlp ( 2013-01-18 06:10:10 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2011-11-17 00:38:08 -0600

asto gravatar image

updated 2011-11-17 00:59:45 -0600

UPDATE This works

# sudo gconftool-2 --direct --config-source xml:readwrite:/etc/gconf/gconf.xml.defaults --type bool --set /apps/gdm/simple-greeter/disable_user_list true

----------

I just checked and changing the settings in gconf-editor and dconf-editor have no effect as you say. If this feature is important to you, consider using KDM (KDE Desktop Manager) as your login screen.

# sudo yum -y install kdm system-switch-displaymanager
# system-switch-displaymanager kdm
edit flag offensive delete link more
1

answered 2011-11-30 09:40:03 -0600

Jon gravatar image

updated 2011-11-30 09:41:36 -0600

The latest versions of GDM3 (with gnome-shell integration) ignore the gconf setting for disable_user_list. Sadly using another display manager (such as KDM) will break other things such as user switching, especially important if users of public machines tend to leave themselves logged in.

The only work around that seems to work for me is to force it to use a "fallback" session.

Steps:

First, ensure that gconf is set up so that the older GDM /would/ be disabling the user list. As root:

# gconftool-2 --direct --config-source xml:readwrite:/etc/gconf/gconf.xml.defaults --type bool --set /apps/gdm/simple-greeter/disable_user_list true

Now, you should perform the following from a text console, or via ssh from another machine, as we will be bringing X up and down:

  • edit /etc/dconf/db/gdm.d/00-upstream-settings, and change session-name to gdm-fallback
  • stop the display manager: service prefdm stop
  • update the dconf database: dconf update
  • start the display manager: service prefdm stop

Thanks to Anders Blomdell for providing the skeleton of the above solution.

The devs are working on implementing support for this (again). You can track progress on this at https://bugzilla.gnome.org/show_bug.cgi?id=660660

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2011-11-15 00:39:36 -0600

Seen: 14,454 times

Last updated: Nov 30 '11