heavy flickering with youtube html5 video

asked 2016-11-29 12:57:10 -0600

Since recently while playing html5 video on youtube, there will be an heavy flicker on the video element.

The flicker is like two images are randomly selected and display one after the other with a few seconds between each other.

Sometimes, it works fine, sometimes it keeps bugging even though firefox is restarted. Rarely, it stops by itself and plays video normally. Note, the sound is not affected (hopefully for me) by this, it always plays smoothly.

Is there anything i could do to fix this ? Thanks!

$ uname -a
Linux pc15-home 4.8.8-300.fc25.x86_64 #1 SMP Tue Nov 15 18:10:06 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

$ lsb_release -a
LSB Version:    :core-4.1-amd64:core-4.1-noarch:cxx-4.1-amd64:cxx-4.1-noarch:desktop-4.1-amd64:desktop-4.1-noarch:languages-4.1-amd64:languages-4.1-noarch:printing-4.1-amd64:printing-4.1-noarch
Distributor ID: Fedora
Description:    Fedora release 25 (Twenty Five)
Release:    25
Codename:   TwentyFive

$ firefox -v
Mozilla Firefox 50.0

$ ps aux | grep X
mh-cbon   1467  1.6  1.6 317636 66448 tty1     Sl+  10:11   9:18 /usr/bin/Xwayland :0 -rootless -noreset -listen 4 -listen 5 -displayfd 6

 $ lspci -v | grep VGA -A 5
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
    Subsystem: Sony Corporation Device 907b
    Flags: bus master, fast devsel, latency 0, IRQ 33
    Memory at c0000000 (64-bit, non-prefetchable) [size=4M]
    Memory at b0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at 8000 [size=64]
--
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M] (rev ff) (prog-if ff)
    !!! Unknown header type 7f
    Kernel driver in use: radeon
    Kernel modules: radeon
edit retag flag offensive close merge delete