Ask Your Question
3

Fedora 25 always thinks airplane mode is enabled

asked 2016-11-29 04:28:31 -0600

wallyk gravatar image

updated 2016-12-13 02:47:53 -0600

I recently upgraded my Lenovo R61 laptop from Fedora 24 to 25. There was no trouble at all running Fedora 20, 21, 22, 23, and 24 on this machine.

Everything seems to work well, except that now it never recognizes the airplane mode switch as being off. Since there are three versions of the Linux kernel available, I have tried booting each of them to see if there is any effect on the behavior. There is not. /boot contains these files:

 -rwxr-xr-x. 1 root root  5897400 Oct  9  2015 vmlinuz-0-rescue-75e870eb13c74fbf97556a32ecf80ea2
 -rwxr-xr-x. 1 root root  6794408 Nov  3 07:51 vmlinuz-4.8.6-201.fc24.x86_64
 -rwxr-xr-x. 1 root root  6792968 Nov 15 12:04 vmlinuz-4.8.8-200.fc24.x86_64
 -rwxr-xr-x. 1 root root  6792968 Nov 15 10:22 vmlinuz-4.8.8-300.fc25.x86_64

Back around Fedora 10, there were various problems on this very same laptop with the Atheros wi-fi driver working poorly. Thankfully those problems are old history.

I have tried both on and off on every kernel, but it always thinks airplane mode is on. Using the gnome doodad for networking, the airplane mode control is disabled and shows on. I can change the wi-fi enabled control, but it has no effect presumably because it thinks airplane mode is on. disabled airplane mode control

I found a suggestion (in a Google search) that installing and using the rfkill package might help, but it also believes the hardware switch is on:

$ rfkill list 
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

Update 1:

I noticed that airplane mode is off for a few seconds after login (though it is only the first time after booting and if the airplane mode switch is off). It is long enough to select a wi-fi network and start typing a password. Perhaps a login setting is forcing airplane mode on? I tried this also with a newly created user and it behaves the same way as my usual login.

Update 2:

Since the upgrade was done through the dnf system-upgrade, I didn't see an explicit check of the file checksum, so it has lingered in the back of my mind that maybe a system file is corrupted. To address this concern, I downloaded the workstation live .iso image and booted that. No configuration necessary: the live image always thinks airplane mode is on.

edit retag flag offensive close merge delete

Comments

1

Thank you for a lucid and detailed description of the issue. Judging by what you've written, it's not kernel related, especially when you see that two of the kernels are fc24, and it worked before the upgrade. Have you tried using a LiveUSB to see if that works? I did a quick search for airplane at the Fedora Bugzilla site, but nothing comes up.

sideburns gravatar imagesideburns ( 2016-11-29 14:55:40 -0600 )edit

@sideburns: Do you mean booting a thumb drive? With which version of Fedora?

wallyk gravatar imagewallyk ( 2016-11-29 15:52:34 -0600 )edit

think sideburns means F25 to see if it works on a vanilla environment.

ceres2009 gravatar imageceres2009 ( 2016-11-29 17:13:25 -0600 )edit

@sideburns: I booted it up on an older Fedora (23?), and wi-fi works just fine.

wallyk gravatar imagewallyk ( 2016-11-29 17:27:23 -0600 )edit

Excellent! That means it's not hardware related. Using F25 will establish if something's changed since F24 or if it's something at your end. (We're using a process of elimination here to limit the possible reasons for your difficulty.)

sideburns gravatar imagesideburns ( 2016-11-29 17:48:33 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-01-20 15:36:30 -0600

wallyk gravatar image

The solution (for me) was to reinstall Fedora 24. F25 has too many annoying issues.

edit flag offensive delete link more

Comments

wallyk gravatar imagewallyk ( 2017-06-13 21:51:43 -0600 )edit

By marking your answer as correct, you prevent others to jump in and help. You may want to consider unticking the check mark. (yes, you loose some karma)

florian gravatar imageflorian ( 2017-11-29 09:18:38 -0600 )edit

@florian: Well, I waited 7 months for an answer. Now it is a year since I first looked for a solution and haven't found a better one. Still, can't someone add another answer anyway?

wallyk gravatar imagewallyk ( 2017-11-29 14:21:53 -0600 )edit

In the meantime we have learned that your Wifi card is a Atheros AR5212. I have done a quick search and it looks like you are not totally alone with problem. Please check if any of the search results are any helpful for you.

https://duckduckgo.com/?q=atheros+ar5...

florian gravatar imageflorian ( 2017-12-01 10:07:35 -0600 )edit

does dmesg | grep failed tell you any new information?

florian gravatar imageflorian ( 2017-12-01 10:08:23 -0600 )edit
0

answered 2017-12-01 10:09:50 -0600

florian gravatar image

updated 2017-12-01 10:10:56 -0600

Have you tried

rfkill unblock all

?

edit flag offensive delete link more

Comments

Oops, already replied in comments to my "answer".

wallyk gravatar imagewallyk ( 2017-12-02 14:22:06 -0600 )edit

Ok, then have you tried to press Fn+F5 several times? Wait after each time and see what the status of your radio devices (wifi and bluetooth) are.

florian gravatar imageflorian ( 2017-12-04 10:33:32 -0600 )edit

Yes, of course I waited. Since the status message doesn't show what it thinks the new state is (whether by design or being clipped off), I tried Fn+F5 about a dozen times each time observing the airplane icon in the top right desktop area and by running rfkill list.

wallyk gravatar imagewallyk ( 2017-12-04 20:57:36 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2016-11-29 04:28:31 -0600

Seen: 1,602 times

Last updated: Dec 01 '17