Ask Your Question
0

Wireless connection not showing in network settings

asked 2016-11-24 09:22:48 -0500

bpc gravatar image

I'm completely new to linux and I've been googling about this problem for the past few hours but nothing I tried seems to work. I've done a full yum update and have Broadcom BCM43142.

edit retag flag offensive close merge delete

Comments

Try install rpmfusion.org and then install akmod-wl. If you are on a current version of Fedora you should be using dnf instead of yum, If you are on a version that uses yum then you probably need to upgrade to Fedora 24 or Fedora 25.

aeperezt gravatar imageaeperezt ( 2016-11-24 11:01:16 -0500 )edit

Oh sorry when I used yum it just redirected to dnf and i didnt notice it. I'm on fedora 25. Also I have already installed akmod-wl.

bpc gravatar imagebpc ( 2016-11-24 11:18:21 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-11-24 18:51:21 -0500

updated 2016-11-24 19:10:45 -0500

I have this problem when I upgrade/reinstall, I have the same wifi controller as you, these are the steps I follow

1) install the RPM Fusion Repositories

[root@localhost ~]# su -c 'dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm'

2) install dev kernel and wifi module

[root@localhost ~]# dnf install kernel-devel-$(uname -r) akmod-wl

3) load the module

[root@localhost ~]# akmods --force
Checking kmods exist for 4.8.8-300.fc25.x86_64 [ OK ]
Building and installing wl-kmod [ OK ]

4) check for errors

[root@localhost ~]# modprobe wl
[root@localhost ~]#

4) restart network manger and hopefully be back up and running

[root@localhost ~]# systemctl restart NetworkManager
edit flag offensive delete link more

Comments

3) I dont get the second line

[root@localhost -]# akmods --force
Checking kmods exist for 4.8.8-300.fc25.x86_64             [  OK  ]
[root@localhost -]#

4) I get one error :

 modprobe: ERROR: could not insert 'wl': Required key not available

I've read that you need to turn off fast boot but I still get the error.

I'm actually stupid. I was turning off fast boot in BIOS not the secure boot. That was the problem.

bpc gravatar imagebpc ( 2016-11-25 05:48:53 -0500 )edit

have you disable Secure Boot in your BIOS options? a quick google for that error suggests thats your problem.

gavtaylor gravatar imagegavtaylor ( 2016-11-26 08:45:51 -0500 )edit
0

answered 2016-11-24 16:24:24 -0500

reclusivegeek gravatar image

Can you add see the Broadcom network controller when you type lspci ?


Do you see any results when you type rpm -qa |grep broadcom


edit flag offensive delete link more

Question Tools

Stats

Asked: 2016-11-24 09:22:48 -0500

Seen: 1,610 times

Last updated: Nov 24 '16