Disable sticky Fn function key in fancy keyboard

asked 2016-11-19 20:53:46 -0600

alfC gravatar image

updated 2016-11-19 22:01:26 -0600

I have a new wireless fancy keyboard (Logitech K400) which by default it has the function keys disabled (and replaced by multimedia keys). I prefer to have function keys instead without pressing the lower Fn key.

Is there a way to do this in Fedora?

Here are the instructions for Windows, which of course doesn't apply to Fedora. http://support.logitech.com/en_us/art...


Logitech deviced are manager by Solaar, I found this but I still couldn't make it work. https://github.com/pwr/Solaar/issues/162

It also looks like Solaar currently only supports K400 Touch but not K400 Plus. https://github.com/pwr/Solaar/blob/ma...

edit retag flag offensive close merge delete

Comments

1

You raise an interesting question. Please note that the most recent comment on the second of your links is over a year and a half old, and things have probably changed. There's a link at the bottom of that page to a forum; have you tried there?

sideburns gravatar imagesideburns ( 2016-11-19 21:33:58 -0600 )edit

@sideburns, thanks. I opened an Issue, I think it is just a matter of not reconizing the string "K400 Plus", I can't believe the hardware is much different otherwise. https://github.com/pwr/Solaar/issues/308

alfC gravatar imagealfC ( 2016-11-19 22:08:25 -0600 )edit