Strange behaviour menu items of applications when running multiple displays

asked 2016-11-19 06:31:05 -0500

GB44 gravatar image

Hi all,

I'm encountering some problems when running certain applications while being connected to a second display. My current setup consists of fedora 25 running Xorg from my laptop (primary screen) and a second display which I connect using VGA. Since I'm reading a lot of PDF with a portrait orientation, I rotate the display 90 degrees anti-clockwise and configure the second screen in the gnome system options accordingly. However, applications such as google chrome and clementine, respectively the list items and menu items don't show up on selection when the applications are on the primary display (the laptop screen). For example, when selecting a menu item in Clementine I can see the menu item is selected, but the submenu does not show up. However, when moving this application to the secondary screen, the submenu shows up, but takes up all the vertical space regardless of the amount of subitems in the list.

Surprisingly, this strange behaviour only occurs when the second display is in the portrait orientation and everything functions as expected when this display is in landscape orientation. However, not all applications suffer from this weird kind of behaviour. For example, the quod libet menu items work fine regardless of the orientation of the secondary screen. Also, whe booting fedora into wayland I run into the same issues.

Does anybody know what could be causing these issues and could help me resolve it? Thanks in advance for your time and effort.

edit retag flag offensive close merge delete