Ask Your Question
0

Dependencies dependencies.. can't be provided

asked 2016-11-19 02:34:16 -0600

elwis gravatar image

updated 2016-11-19 02:53:44 -0600

Hi all, I'm running Fedora25/KDE spin and planned to play around with KDEvelop/QT5 for the weekend to get some rest from all those Jars & javascripts. However, something isn't playing nice, pehaps it is the fact that I'm running Fedora25 but it would be nice to get a solution to these errors. When I'm trying to install qt-devel it gives me:

package qt-devel-1:4.8.7-18.fc25.x86_64 requires pkgconfig(gl), but none of the providers can be installed

So I google and realize I might need libMesa and tries to install it which gives me

package mesa-libGL-devel-12.0.3-3.fc25.i686 requires pkgconfig(libdrm) >= 2.4.66, but none of the providers can be installed

I can see where this is going. Maybe I'm doing something wrong, I haven't been in Red hat land for a couple of years unfortunately.

Regards

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-11-19 11:50:56 -0600

elwis gravatar image

Oh.. this was weird. Looks like qt and all the goodies got installed after all? So to be honest, I have no clue what happened with those awkward messages there but anyway I can play with the KDE/Qt libs all night so I'll be just fine.

Have a nice weekend all of you

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-11-19 02:34:16 -0600

Seen: 84 times

Last updated: Nov 19 '16