Ask Your Question
0

Grub Customizer Compile Error

asked 2016-11-16 21:24:35 -0600

graceful gravatar image

updated 2016-11-17 03:16:54 -0600

florian gravatar image

When I try to compile Grub Customizer I get the following error:

Scanning dependencies of target grub-customizer
[ 12%] Building CXX object CMakeFiles/grub-customizer.dir/src/main/client.cpp.o
[ 25%] Building CXX object CMakeFiles/grub-customizer.dir/src/Bootstrap/GtkView.cpp.o
In file included from /home/sophie/Desktop/grub-customizer-5.0.6/src/Bootstrap/GtkView.cpp:18:0:
/home/sophie/Desktop/grub-customizer-5.0.6/src/Bootstrap/../View/Gtk/About.hpp:23:19: fatal error: gtkmm.h: No such file or directory
 #include <gtkmm.h>
                   ^
compilation terminated.
CMakeFiles/grub-customizer.dir/build.make:86: recipe for target 'CMakeFiles/grub-customizer.dir/src/Bootstrap/GtkView.cpp.o' failed
make[2]: *** [CMakeFiles/grub-customizer.dir/src/Bootstrap/GtkView.cpp.o] Error 1
CMakeFiles/Makefile2:67: recipe for target 'CMakeFiles/grub-customizer.dir/all' failed
make[1]: *** [CMakeFiles/grub-customizer.dir/all] Error 2
Makefile:127: recipe for target 'all' failed
make: *** [all] Error 2
[xxxxxx@localhost grub-customizer-5.0.6] $
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2016-11-18 02:25:47 -0600

graceful gravatar image

updated 2016-11-18 02:27:25 -0600

After verifying the "very old" documentation regarding image requirements in Launchpad:


https://launchpad.net/grub-customizer


I verifed that the image I was using was acceptable.


One of the comments here, that I can't seem to relocate was that:


/etc/default/grub >> GRUB_TERMINAL_OUTPUT could NOT be in console mode, which it was:


GRUB_TERMINAL_OUTPUT="console"


The following:


"#GRUB_TERMINAL_OUTPUT="console""


remedied that problem.


Also, I had to uncomment #GRUB_GFXMODE="saved" and edit it to look like this GRUB_GFXMODE="640x480"


Grub Customizer WON'T do ANY of this for you!


I then had to update grub manually by executing:


su -c 'grub2-mkconfig -o /boot/grub2/grub.cfg'


As my system is MBR.


Finally, my splash image displayed properly behind the GRUB boot menu.


Everything is now all "Rainbows, Lollipops and Unicorns," yeah!


edit flag offensive delete link more
1

answered 2016-11-17 03:15:11 -0600

florian gravatar image

Do you really need to compile the newest version? I would start off with what is in the official repository. Install the rpm by running sudo dnf install grub-customizer

edit flag offensive delete link more

Comments

Thanks for the reply,

I was unable to locate this in gnome-software-center. That's why I resorted to compiling. However, the code you provided worked like a champ; and I now have grub-customizer installed.


I was able to change the font color but not the background image. It is a .jpg and the resolution is 640 x 480; and it won't load. I don't think it's the image; because I've used the same image on Ubuntu 14.04.


What am I missing, thanks?

graceful gravatar imagegraceful ( 2016-11-17 16:12:12 -0600 )edit

dnf search xyz will be your command in the future. Gnome Software is not showing a complete inventory of your repositories, and actually messes up reliable dnf functionality. Better get used to the basic operation of dnf...

florian gravatar imageflorian ( 2016-11-17 19:44:54 -0600 )edit

as for your background picture, sorry, I have no clue.

florian gravatar imageflorian ( 2016-11-17 19:45:25 -0600 )edit

Just installed grub-customizer via DNF on F25: Installs, but fails to execute.

e-inquirer gravatar imagee-inquirer ( 2016-12-02 03:47:16 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2016-11-16 21:24:35 -0600

Seen: 424 times

Last updated: Nov 18 '16