Ask Your Question
0

Unable to set hotkeys for workspace switching vertically using both modifiers (maybe just a functional problem now, hotkeys were fine)

asked 2016-11-15 22:14:11 -0600

Pysis gravatar image

updated 2016-11-16 21:30:54 -0600

I want to make workspace switching via the hotkey, vertically, more consistent with the existing horizontal hotkeys; just my whim here so far.

In the (GNOME?) Settings window, I go to Keyboard, and found them in the Navigation section (not the Window Management (Ubuntu-only, I guess) or (Custom?) shortcuts sections), after scrolling down to Move to workspace _____.

I was able to engage the input mode, and change it to either Ctrl+Up or Alt+Up, but not Ctrl+Alt+Up as I wanted, as it still waited for input with the text "New Accelerator".

Key combinations such as "Ctrl+Alt+K" can be bound using both of those modifier keys to a custom shortcut, as an example.

Don't see anything for Windows in this list of hotkeys as it is my Host OS, only what we would expect for GNOME: https://en.wikipedia.org/wiki/Table_o... Also referred to this link to find the hotkeys for VirtualBox, and did not see any that should cause a conflict at first glance, only single 'Ctrl' or 'Host' key combinations, but nothing with both or involving Left Alt at all, since Right Alt is my currently set Host Key, which is also reflected in that same window.

Environment I am using Fedora 24 through Virtualbox 5 with the Host key set to "Right Alt". Host OS is Windows 10 Pro 64-bit.

Also did not help:

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-11-15 22:26:13 -0600

Pysis gravatar image

updated 2016-11-18 22:08:02 -0600

I guess I will have to go through dconf-editor (not gconf-editor for some reason, w/e).

Finally found the keys as strings under org > gnome > desktop > wm > keybindings : switch-to-workspace-_____. Editing values around by looking at the other presets seems self-explanatory, example: move-to-workspace-left = ['<Control><Shift><Alt>Left']

Updates:

Strangely enough, the move-to-workspace-_____ keys seem to be dual-set to my liking already.

Looks like the keys for moving to workspaces above and below are also dual-set to my liking too, but only the first is reflected in the gnome-tweak-tool misleadingly, maybe as to why I cannot change to that key combination, as it is already set to that property.

The hotkeys do not work using the arrow keys, only the Page- keys. This may be a slightly different issue now. The situation does not improve, even if I move the string for my preferred Ctrl-Alt key combination as the first item in the string array for each property.

Also, I am able to set hotkeys using both of my preferred modifier keys now. I do not need to do this for the properties I need to work with, but I tested this in a custom shortcut just to be sure I could.

Now my problem seems to just getting the switch workspace function to work with the arrow keys..

I found that by checking "Auto Capture Keyboard" under File -> Preferences -> Input, this allowed me to switch workspaces. ( https://forums.virtualbox.org/viewtop... ) I will probably use this as an answer now, but I cam still curious as to what interaction is directly preventing this. Maybe it's as convoluted as the way Windows recognizes multiple modifier keys for input, and changes its own 'mode', but that doesn't translate as inputs to the VM? Don't know; that was just a speculation.

edit flag offensive delete link more

Comments

Most settings are set in dconf now. gconf is deprecated.

ssieb gravatar imagessieb ( 2016-11-16 13:45:51 -0600 )edit

Yea, kinda figured that, but apparently gsettings is the CLI program to use.

Pysis gravatar imagePysis ( 2016-11-16 21:32:15 -0600 )edit
0

answered 2016-11-16 13:48:25 -0600

ssieb gravatar image

As you discovered, the default hotkeys for workspace switching is CTRL-ALT-arrow. You don't mention what the host OS is. I expect you are running into either Virtualbox or the host OS handling that key combination so it doesn't make it to the VM.

edit flag offensive delete link more

Comments

Updated main question text with host OS information, and checked hot keys for all systems: the Host OS, VirtualBox, and the guest Fedora 24/Linux VM. I don't see anything that would cause a conflict.

Pysis gravatar imagePysis ( 2016-11-16 21:31:49 -0600 )edit

I don't know if I can help you then. I have had no problems running various versions of Fedora with Gnome in KVM under Fedora and having the workspace keys work. But I have no use for virtualbox or Windows... However, a quick Google search suggests that ctrl-alt-arrow combinations are used for screen rotation in Windows 10.

ssieb gravatar imagessieb ( 2016-11-18 13:43:32 -0600 )edit

That is a good point, and after checking various sources such as this one ( http://www.sevenforums.com/graphic-ca... ), I don't think my version of the nVidia Control Panel software comes with those hotkeys and/or configuration, only the manual feature to rotate the screen. I did research something else ( https://forums.virtualbox.org/viewtop... ) to have my guest only recognize OS hotkeys including the Alt+Tab combination, and found by checking "Auto Capture Keyboard", that seems to improve my issue.

Pysis gravatar imagePysis ( 2016-11-18 22:05:25 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2016-11-15 22:14:11 -0600

Seen: 277 times

Last updated: Nov 18 '16