Ask Your Question
0

How to disable INS (insert) key

asked 2016-11-12 18:14:09 -0600

alfC gravatar image

I have Fedora 24 with Gnome. Is there a way to disable the Insert key (I press it accidentally all the time).

I was able to map CapsLock to Control in Gnome Tweaks, but I didn't find any option regarding Insert.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-11-16 09:32:04 -0600

ptrck4193 gravatar image

updated 2016-11-16 13:45:14 -0600

At a terminal, enter C-v Ins (CTRL and v combined then released, then the insert key). My output is ^[[2~. The ^[ is the ESC key. As proof, enter C-v Esc. To search the key binding, enter

bind -p | grep "\e\[2\~"

where \e is ESC. Using the utility bind, change or remove the key binding. For instance, by entering

bind '"\C-x\C-w\C-w":"Hi from the terminal!"'

I can enter CTRL-xCTRL-wCTRL-w and the quote is placed on the command line. Also, examine the utility "xmodmap". See topic EXAMPLES, specifically the one to set the keyboard's "rubout" key to generate an alternate keysym. This is an X Windowing System utility so I don't know how it will play-out with Wayland. Even so, applications may have their own specific key bindings.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-11-12 18:14:09 -0600

Seen: 393 times

Last updated: Nov 16 '16