Will not power off, without gpu.

asked 2016-10-29 14:50:20 -0600

helloyes gravatar image

Hello. I'm running Fedora 24 as a home media server. Most everything is perfect, however there is a problem with trying to shutdown the machine. I noticed the issue a while ago, but given that it was so easily accessible i did not bother to try and fix it until now.

The problem is, when i issue a shutdown or reboot command, the pc will not power off. Now, i'm not exactly certain what is going on, i'm running it headless. As far as i can tell, the shutdown goes fine, but for some reason the machine will not power off. If i hit the power button it turns off immediately, and will start back up just fine.

From various googlelings i have tried a few things. However first of all, a strange thing happens. I put in an old gpu in the machine to try and see the screen output during shutdown, and there was no need because it works perfectly when the gpu is in. With the gpu in it will reboot fine if given the command either on the machine itself or through ssh. Take the gpu out and issue the reboot command via ssh and it will fail.

I have tried messing with the power setting of the mobo bios, no help. The only setting of note is i have it set to wake after a power failure and power returns, but same thing happens whether it is off or on.

I have tried setting acpi=off in /etc/default/grub, it has no effect.

Here is a journalctl output from a past boot, 'journalctl -b -1 -r':

Oct 29 17:33:17 lola.longford systemd-journald[460]: Journal stopped
Oct 29 17:33:17 lola.longford systemd[1]: Set hardware watchdog to 10min.
Oct 29 17:33:17 lola.longford systemd[1]: Hardware watchdog 'iTCO_wdt', version 0
Oct 29 17:33:17 lola.longford systemd[1]: Shutting down.
Oct 29 17:33:17 lola.longford systemd[1]: Starting Reboot...
Oct 29 17:33:17 lola.longford systemd[1]: Reached target Final Step.
Oct 29 17:33:17 lola.longford systemd-shutdown[1]: Sending SIGTERM to remaining processes...
Oct 29 17:33:17 lola.longford kernel: watchdog: watchdog0: watchdog did not stop!
Oct 29 17:33:17 lola.longford systemd[1]: Reached target Shutdown.
Oct 29 17:33:17 lola.longford systemd[1]: Stopped Remount Root and Kernel File Systems.
Oct 29 17:33:17 lola.longford systemd[1]: Stopped Create Static Device Nodes in /dev.
Oct 29 17:33:17 lola.longford systemd[1]: Stopping Monitoring of LVM2 mirrors, snapshots etc. using dmeventd or progress polling...
Oct 29 17:33:17 lola.longford systemd[1]: Stopped target Local File Systems (Pre).
Oct 29 17:33:17 lola.longford systemd[1]: Removed slice system-systemd\x2dfsck.slice.
Oct 29 17:33:17 lola.longford systemd[1]: Stopped File System Check on /dev/disk/by-uuid/b8b243fd-9158-4e6c-8b7d-d586d49d7852.
Oct 29 17:33:17 lola.longford systemd[1]: Reached target ...
(more)
edit retag flag offensive close merge delete

Comments

I see a hardware watchdog set to 10 minutes. Wait ten minutes, see if that trips tt, and if it goes off, then consider a shorter delay.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-02-06 11:16:11 -0600 )edit