Ask Your Question
0

How do I set Iron as my default browser in Fedora 17?

asked 2012-08-23 14:12:48 -0600

Nathan gravatar image

updated 2012-08-23 15:03:43 -0600

On my newly installed Fedora 17 Desktop Edition 64-bit (Gnome), I downloaded SRWare Iron via their .rpm from here. After installing it, I ran it and it asked me if I wanted to make Iron the default browser. I clicked yes. This didn't actually do anything, however. When I go to the Default Applications tab on the Details application, it still says Chromium Web Browser (which I had previously set it as). Iron also does not show up in the drop down box.

As a quick test, I opened Terminator and echoed a URL, which I then CTRL clicked. It opened the website in Chromium, not Iron.

Is there a way to set Iron as a "browser" according to my system, so I can select it in the drop down box, or a command I can run to set it as default?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-08-23 15:33:30 -0600

davidva gravatar image

updated 2012-08-23 15:47:54 -0600

Try it:

From a terminal

su -c 'yum -y install gconf-editor'


gconf-editor

Go

From gconf-editor

/desktop/gnome/applications/browser

In the right hand pane, right click on the exe key and swap out firefox for iron.

From a terminal

su -c 'ln -sf /usr/share/iron/iron /etc/alternatives/x-www-browser'
edit flag offensive delete link more

Comments

And for KDE?

Santosh gravatar imageSantosh ( 2018-11-12 23:57:26 -0600 )edit

Question Tools

Stats

Asked: 2012-08-23 14:12:48 -0600

Seen: 3,090 times

Last updated: Aug 23 '12