Ask Your Question
0

Clang++ not working in Fedora 17?

asked 2012-08-01 01:14:17 -0600

alfC gravatar image

A hello world c++ program can't be compiled with clang++ in Fedora 17, because it gives the following cryptic message. Do anybody know a solution to this?

In file included from /usr/bin/../lib/gcc/x86_64-redhat-linux/4.7.0/../../../../include/c++/4.7.0/iostream:39:
In file included from /usr/bin/../lib/gcc/x86_64-redhat-linux/4.7.0/../../../../include/c++/4.7.0/ostream:39:
In file included from /usr/bin/../lib/gcc/x86_64-redhat-linux/4.7.0/../../../../include/c++/4.7.0/ios:42:
In file included from /usr/bin/../lib/gcc/x86_64-redhat-linux/4.7.0/../../../../include/c++/4.7.0/bits/ios_base.h:40:
/usr/bin/../lib/gcc/x86_64-redhat-linux/4.7.0/../../../../include/c++/4.7.0/ext/atomicity.h:48:45: error: 
      use of undeclared identifier '__ATOMIC_ACQ_REL'
  { return __atomic_fetch_add(__mem, __val, __ATOMIC_ACQ_REL); }
                                            ^
/usr/bin/../lib/gcc/x86_64-redhat-linux/4.7.0/../../../../include/c++/4.7.0/ext/atomicity.h:52:38: error: 
      use of undeclared identifier '__ATOMIC_ACQ_REL'
  { __atomic_fetch_add(__mem, __val, __ATOMIC_ACQ_REL); }

The helloworld program is:

#include<iostream>
int main(){
return 0;
}

the command line is

clang++ helloworld.cpp
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-08-02 14:43:17 -0600

clee gravatar image

You should file a bug report. Read http://fedoraproject.org/wiki/Howtofileabug_report and follow the directions there!

edit flag offensive delete link more

Comments

alfC gravatar imagealfC ( 2012-08-03 21:42:01 -0600 )edit

from what I could follow in the bug report, this will not be fixed for Fedora 17.

alfC gravatar imagealfC ( 2012-10-10 22:01:02 -0600 )edit

Question Tools

Stats

Asked: 2012-08-01 01:14:17 -0600

Seen: 1,646 times

Last updated: Aug 02 '12