Ask Your Question
0

Can't set acl in /etc/fstab

asked 2016-10-18 12:25:29 -0600

updated 2016-10-19 16:43:05 -0600

sideburns gravatar image

Hi folks, I have a problem with setting acl to my any of my mounted fs's. My /etc/fstab looks like:

/dev/mapper/fedora_kami--01-root /                       ext4    defaults,acl        1 1

/dev/mapper/fedora_kami--01-home /home                   ext4    rw,acl              1 2

/dev/mapper/fedora_kami--01-swap swap                    swap    defaults            0 0

I tried remounting and rebooting but still i can't see that it's enabled.

I use mount | grep acl to check.

Thanks in advance!

edit retag flag offensive close merge delete

Comments

Are you able to mount it manually by using: mount -o acl BlockDevice MountPoint?

jake gravatar imagejake ( 2016-10-19 05:42:59 -0600 )edit
1

Try running sudo mount -a in a terminal and see if there are any error messages.

sideburns gravatar imagesideburns ( 2016-10-19 16:59:33 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-10-20 20:16:10 -0600

snowolfe gravatar image

If you are using F24 (as indicated by the tag attached to this question), then acl, along with user_xattr, is already a default option on ext4 filesystems.

To verify this:

$ sudo tune2fs -l /dev/mapper/fedora_kami--01-root | grep 'Default mount'

Should return:

Default mount options: user_xattr acl

These default mount options don't seem to appear when running mount - not sure why.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2016-10-18 12:23:49 -0600

Seen: 107 times

Last updated: Oct 20 '16