Ask Your Question
0

dnf update fails on a fresh install

asked 2016-10-16 02:07:58 -0600

updated 2016-10-16 02:12:21 -0600

I have just installed Fedora 24. Now as Fedora 24 doesn't come with Broadcom chip firmware pre-installed I have decided to install this firmware from a chroot on my Ubuntu 16.10 install (which does have the required firmware to connect to the Wi-Fi using my Broadcom chip). So to be clear, I have a Ubuntu 16.10 installation, alongside my Fedora 24 installation, and in this 16.10 install I am running:

# mount /dev/sda2 /mnt/fedora && arch-chroot /mnt/fedora /bin/bash

where my Fedora 24 install is on /dev/sda2. In this chroot I am going to follow instructions I provided on a previous answer here. Before I do this I have to run:

# dnf update

But this command has given me the error:

Error: Failed to synchronize cache for repo 'updates'

So I am here to ask how do I fix this error?

edit retag flag offensive close merge delete

Comments

Can't you just copy the firmware from your ubuntu installation to fedora?

fcomida gravatar imagefcomida ( 2016-10-16 05:51:54 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-10-17 16:53:20 -0600

ssieb gravatar image

The chroot is not going to have all the system mounts setup properly (/proc, /dev, /sys, etc.), so a lot of things are not going to work. The best way would be to connect your laptop using an ethernet cable. Then setup the rpmfusion repositories and run dnf install akmod-wl kernel-devel. After you reboot, it should be working.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-10-16 02:07:58 -0600

Seen: 316 times

Last updated: Oct 17 '16