Ask Your Question
1

How to manually set the monitor refresh rate?

asked 2016-10-15 18:52:30 -0600

Polish Hacker gravatar image

I have a Dell P2415Q Monitor capable of UHD resolution at 60Hz. I was able to use the display with a resolution of 3840x2160 at 60Hz on both Windows 10 and Ubuntu 16.04, so I'm sure the monitor can handle 60Hz.

On Fedora 24, I am shown the proper resolution (which works great), but my options for Refresh Rate are 29Hz and 59Hz:

image description

I would like to use the native 60Hz refresh rate this monitor is capable of. How can I set up my monitor to a 60Hz refresh rate?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-10-17 14:30:47 -0600

ssieb gravatar image

How do you know that the monitor can actually do 60Hz? (The numbers on the box don't count.)

Run dnf install monitor-edid. If you have only a single monitor, then just try running monitor-edid -v. If you have more or that doesn't show you what you expect, then in a terminal, look in /sys/class/drm and find the output your monitor is connected to. In my case, I have two monitors on card0-DVI-I-1 and card0-DVI-I-2. Then run (for example) monitor-parse-edid -v < /sys/class/drm/card0-DVI-I-2/edid.

(Yes, I know you only have one monitor, but I think it would be useful to provide the general answer as well.)

edit flag offensive delete link more

Comments

The display settings built into the monitor report the refresh rate and it has been accurate with other systems so I trust its reporting. When running monitor-edid -v I get # Monitor preferred modeline (60.0 Hz vsync, 133.3 kHz hsync, ratio 16/9, 185 dpi) <newline> ModeLine "3840x2160" 533.25 3840 3902 3950 4000 2160 2163 2168 2222 -hsync +vsync in the result. I also get parsing EDID from /sys/class/drm/card0-DP-1/edid so looks like my monitor is on card0-DP-1. Running # monitor-parse-edid -v < /sys/class/drm/card0-DP-1/edid does not seem to give me 60Hz, even after restart.

Polish Hacker gravatar imagePolish Hacker ( 2016-10-17 15:44:17 -0600 )edit

Also, when running either monitor-edid -v or monitor-parse-edid -v, the output starts with Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/.*? = { <-- HERE / at /usr/bin/monitor-parse-edid line 735.. Maybe this is causing my troubles?

Polish Hacker gravatar imagePolish Hacker ( 2016-10-17 15:48:30 -0600 )edit

After running the commands a few more times with a few trial-and-error modifications, it seems like my monitor is now reporting 60Hz. I'm not sure exactly what made it work but it's working now based on your answer. Settings in Gnome unfortunately continues to only show 59Hz and 29Hz.

Polish Hacker gravatar imagePolish Hacker ( 2016-10-17 15:57:57 -0600 )edit

The warning doesn't seem to be a problem at this point, but it might become one in the future.

What is the output of xrandr?

ssieb gravatar imagessieb ( 2016-10-17 16:03:42 -0600 )edit

Screen 0: minimum 8 x 8, current 3840 x 2160, maximum 32767 x 32767 <newline> DP1 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 530mm x 300mm <newline> 3840x2160 60.00*+ 29.98 <newline> 2560x1440 59.95 <newline> . . . and then it continues to list many resolutions below 3840x2160 with various refresh rates, except none of them have the *+ symbols next to them like 60.00*+ next to 3840x2160.

Polish Hacker gravatar imagePolish Hacker ( 2016-10-17 17:20:27 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2016-10-15 18:52:30 -0600

Seen: 2,679 times

Last updated: Oct 17 '16