Ask Your Question
1

Any idea why Gnome Tweak tool does not turn on desktop icons when set to "ON"

asked 2016-10-13 20:27:17 -0600

pyrrhic gravatar image

updated 2016-10-15 07:00:08 -0600

hhlp gravatar image

Clean install on newly formatted space. No error messages on install nor on Gnome tweak tool install. Tweak tool appears to provide its other functions normally. However, setting desktop icons and associated functionality to "ON" has no effect, nor does it cause any message to pop up. All suggestions would be appreciated. Platform is i7 intel, with UEFI.

In case anyone asks:

gsettings get org.gnome.desktop.background show-desktop-icons

...it answers back...

true

...as it should.

Best and thanks, Pyrrhic

edit retag flag offensive close merge delete

Comments

Thank you JMT! I was away from Fedora for a few years and - barely - knew FC25 was moving to Wayland. I really appreciate the answer as it was driving me crazy. Especially as the tweaker was mostly working. Desktop icons are important to me so I see I will have to do some research ... obviously Xorg is one way to handle it - thank you also for suggesting a solution. I would upvote your answer but do not have enough points as yet. I am sure, however, that others are going to be 'caught out' by this too.

pyrrhic gravatar imagepyrrhic ( 2016-10-14 12:46:19 -0600 )edit

@pyrrhic Hi, Fedora 25 is still in development (Fedora_Release_Life_Cycle is still not final). If you find a problem, you should report a bug.

hhlp gravatar imagehhlp ( 2016-10-15 06:35:07 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-10-14 10:12:45 -0600

jmt gravatar image

Fedora 25 is using Wayland by default instead of Xorg. Desktop icons are not supported on Wayland. You can select "Gnome on Xorg" on the login screen.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-10-13 20:07:32 -0600

Seen: 1,795 times

Last updated: Oct 15 '16