Ask Your Question
0

Grub is not showing windwos at startup

asked 2016-10-12 06:52:51 -0500

Jaaz gravatar image

When i boot up, grub opens but i only see 2 versions of fedora, no windows.. Efi boot menu doesn't show windows. As far as i know, i have not reformatted the EFI partition.. And i did not create a new partition before installing it, it went with auto partiotion...

Here's fdisk -l

Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors Units: sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 4096 bytes I/O size (minimum/optimal): 4096 bytes / 4096 bytes Disklabel type: gpt Disk identifier: 6E1A4C88-C3C3-4A2F-8641-BB5DA1C3C5F1

Device Start End Sectors Size Type /dev/sda1 2048 923647 921600 450M Windows recovery environment /dev/sda2 923648 1128447 204800 100M EFI System /dev/sda3 1128448 1161215 32768 16M Microsoft reserved /dev/sda4 1161216 1933043711 1931882496 921.2G Microsoft basic data /dev/sda5 1933043712 1933045759 2048 1M BIOS boot /dev/sda6 1933045760 1934069759 1024000 500M Linux filesystem /dev/sda7 1934069760 1953523711 19453952 9.3G Linux LVM

Disk /dev/mapper/fedora-root: 8.3 GiB, 8904507392 bytes, 17391616 sectors Units: sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 4096 bytes I/O size (minimum/optimal): 4096 bytes / 4096 bytes

Disk /dev/mapper/fedora-swap: 1004 MiB, 1052770304 bytes, 2056192 sectors Units: sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 4096 bytes I/O size (minimum/optimal): 4096 bytes / 4096 bytes

Still can't find windows.

[root@localhost jaaz]# grub2-mkconfig -o /boot/grub2/grub.cfg Generating grub configuration file ... Found linux image: /boot/vmlinuz-4.5.5-300.fc24.x86_64 Found initrd image: /boot/initramfs-4.5.5-300.fc24.x86_64.img Found linux image: /boot/vmlinuz-0-rescue-5f58e430bcd348ae977399a1de7d6f79 Found initrd image: /boot/initramfs-0-rescue-5f58e430bcd348ae977399a1de7d6f79.img done

Here's entries in bootloader

[root@localhost jaaz]# grep menuentry /boot/grub2/grub.cfg if [ x"${feature_menuentry_id}" = xy ]; then menuentry_id_option="--id" menuentry_id_option="" export menuentry_id_option menuentry 'Fedora (4.5.5-300.fc24.x86_64) 24 (Workstation Edition)' --class fedora --class gnu-linux --class gnu --class os --unrestricted $menuentry_id_option 'gnulinux-4.5.5-300.fc24.x86_64-advanced-baa11a9f-470f-4966-a7ec-83969dcd3d2f' { menuentry 'Fedora (0-rescue-5f58e430bcd348ae977399a1de7d6f79) 24 (Workstation Edition)' --class fedora --class gnu-linux --class gnu --class os --unrestricted $menuentry_id_option 'gnulinux-0-rescue-5f58e430bcd348ae977399a1de7d6f79-advanced-baa11a9f-470f-4966-a7ec-83969dcd3d2f' {
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-10-13 08:47:33 -0500

youssefmsourani gravatar image

You should boot from flash memory at UEFI Mode and install fedora ,You have parttion BIOS boot on /dev/sda6 this means fedora installed in LegacyBios/gpt.

[ -d /sys/firmware/efi/efivars ] && echo EFI || echo Legacy Bios

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-10-12 06:52:51 -0500

Seen: 91 times

Last updated: Oct 12 '16