Ask Your Question
2

How to enable rts5139 kernel module?

asked 2012-04-10 19:08:11 -0600

tzicatl gravatar image

updated 2012-05-24 11:28:17 -0600

I have an Acer S3. It has a card reader and It seems I can make it work by enabling the rts5139 module.

Right now, modprobe rts5139 gives an error. The module is not present. But a search in my hard drive reveals that there's a Makefile in some directory with that name:

$ locate rts5139
/usr/src/kernels/3.3.0-4.fc16.x86_64/drivers/staging/rts5139
/usr/src/kernels/3.3.0-4.fc16.x86_64/drivers/staging/rts5139/Kconfig
/usr/src/kernels/3.3.0-4.fc16.x86_64/drivers/staging/rts5139/Makefile

It's been several years since I last compiled a kernel. What are these "staging" drivers?

How do I enable one of them?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-04-11 06:47:27 -0600

FranciscoD_ gravatar image

Hi there!

The kmod-staging package in RPMFusion should contain these modules.

Please set up RPMFusion as explained on rpmfusion.org. You'll need both the free and non free repositories. Once done, run the command:

su -c 'yum install kmod-staging'

and reboot. That should do it.

edit flag offensive delete link more

Comments

Hi, I have the same problem, I've installed kmod-staging successfully (confirmed by the terminal when I run the yum install command), but no life sign from the sdcard (which works on other computers...). If you know what's the problem, feel free to answer here or on my question "How to install the correct card reader drivers on F21". Thank you in advance!

Pella gravatar imagePella ( 2015-04-20 03:45:29 -0600 )edit

Question Tools

Stats

Asked: 2012-04-10 19:08:11 -0600

Seen: 3,967 times

Last updated: May 24 '12