Ask Your Question
1

Two screensavers? How to remove xcreensaver?

asked 2016-10-10 19:34:24 -0600

benitezCarvalho gravatar image

updated 2016-10-11 18:22:30 -0600

Hi folks, I recently installed XFCE in my Fedora 24 to test it, and I already have GNOME. But I'm having some trouble with xcreensaver. Actually I think there are two screensavers running together. Sometimes, when I close and open my laptop, after entering my password in GDM, I have to type again in xscreensaver (using GNOME). I just want to use GDM to login and the default gnome-screensaver. But I can't remove xcreensaver by running sudo dnf remove xscreensaver. Can anyone help me? I would really appreciate it. Tks

edit retag flag offensive close merge delete

Comments

Run this in a terminal: ps aux | grep screensaver | grep -v grep and see how many lines of output you get.

sideburns gravatar imagesideburns ( 2016-10-12 00:17:01 -0600 )edit

in xfce:(1) in gnome(2)

  1. benitez+ 1874 0.1 0.1 219132 8464 tty2 S+ 17:39 0:00 xscreensaver -no-splash
  2. benitez+ 3257 0.1 0.0 166308 4848 tty2 S+ 17:43 0:00 xscreensaver -nosplash
benitezCarvalho gravatar imagebenitezCarvalho ( 2016-10-15 15:46:06 -0600 )edit

Thank you. Line one is (or should be) OK, as it's your only screensaver. It shouldn't be running in Gnome, however, unless you don't have gnome-screensaver installed. If I were running Gnome, I'd check to see if it's listed in the autostart programs and if so, disable it. BTW, did you completely log out of your Xfce session and log in with Gnome, or just switch from one DE to the other? It might make a difference.

sideburns gravatar imagesideburns ( 2016-10-15 17:15:13 -0600 )edit

In fact, I don't have gnome-screensaver installed. And yes, I completely logged out. I think I'm confused. What I really meant, is that after logging in in GDM, I have to unlock again in xscreensaver. Sorry if I have confused you too

benitezCarvalho gravatar imagebenitezCarvalho ( 2016-10-17 20:26:55 -0600 )edit

In that case, run xscreensaver-demo and check your settings.

sideburns gravatar imagesideburns ( 2016-10-17 21:35:07 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-10-10 22:12:00 -0600

sideburns gravatar image

Judging from personal experience back when I used Gnome, it will always use gnome-screensaver if it's installed, even if you've set your system up to use xscreensaver instead. To make sure that xscreensaver isn't installed, try this:

sudo dnf remove *xscreensaver*

This will get rid of all packages involved in xscreensaver, including rss-gls-xscreensaver which might be missed otherwise. If that doesn't clear things up, xscreensaver isn't the issue and might not even have been installed.

edit flag offensive delete link more

Comments

That was my mistake when posting this... haha. I'm pretty sure that xscreensaver is already installed. But the only way I can fix this is removing xfce :/

benitezCarvalho gravatar imagebenitezCarvalho ( 2016-10-11 18:25:56 -0600 )edit

Why? Gnome doesn't have xscreensaver as a dependency, in fact, it doesn't want it in use.

sideburns gravatar imagesideburns ( 2016-10-12 00:11:38 -0600 )edit

I know that xscreensaver is installed because it blocks my screen when I open my laptop and it is in the applications list. Also, when I run dnf install @xfce-desktop-environment to install xfce, xscreensaver appears in the dependences list: **xscreensaver-base x86_64 1:5.35-4.fc24 updates 426 k


benitezCarvalho gravatar imagebenitezCarvalho ( 2016-10-15 11:13:55 -0600 )edit

If that's listed as a dependency, that means that it isn't installed, not that it is. You asked for help, I've given you suggestions, but all I get back are arguments. If you want any further help from me, start taking my suggestions and posting the results.

sideburns gravatar imagesideburns ( 2016-10-15 13:15:22 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2016-10-10 19:34:24 -0600

Seen: 1,853 times

Last updated: Oct 11 '16