Ask Your Question
0

glibc too new to install e.g. glibc-devel

asked 2013-01-01 06:35:47 -0600

Ypsilon gravatar image

updated 2014-09-30 11:13:31 -0600

mether gravatar image

Hi,

I'm figuring out a very strange and annoying problem on Fedora 18 beta, on which I can't find any topic on other forums on the internet on the Internet.

I'm just trying to install glibc-devel, but it has dependency to glibc = 2.16-24.fc18, but I have glibc = 2.16-28.fc18 installed. It seems that -24 is available over fedora-repo and -28 is from updates-testing.

How can I tell glibc-devel (and some other packages with the same problem) to ignore the wrong version or get the suitable version of glibc?

Thanks in Advance. Ypsilon

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-01-04 13:23:34 -0600

Why use reposync?

Ensure /etc/yum.repos.d/fedora-updates-testing.repo is disabled (enabled=0), then run

# yum distro-sync

All your packages will be downgraded appropriately.

edit flag offensive delete link more

Comments

D'oh! My brain must have been out to lunch... I'm removing my answer in favor of your correct one.

randomuser gravatar imagerandomuser ( 2013-01-05 18:26:12 -0600 )edit

Question Tools

Stats

Asked: 2013-01-01 06:35:47 -0600

Seen: 417 times

Last updated: Jan 05 '13