Ask Your Question
0

Cant launch Steam libGL error

asked 2016-10-07 22:01:22 -0600

kil1mple gravatar image

Hello !

I have a problem i cant launch Steam on Fedora 24.I installed the nvidia driver 370 today and got an error at the end:

image description

So i tried to open with terminal:

[nico@localhost bin]$ ./steam 
Running Steam on fedora 24 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1474415843)
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

I hope you guys can help me solve this problem.Do i need to create a simlink with libEGL.so.1 or something ?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-10-08 06:56:55 -0600

jake gravatar image

You are running a 64 bit system, but most games are 32 bit applications. You need to provide a 32 bit version of the Mesa libEGL runtime libraries

To do so run this command:

sudo dnf install mesa-libEGL-12.0.3-1.fc24.i686

If you have the proprietary Nvidia drivers installed, run this command instead:

sudo dnf install xorg-x11-drv-nvidia-libs.i686

edit flag offensive delete link more

Comments

Now fedora doesnt boot.Its just blinking in the left corner.I can do control alt f2.I installed the nvidia driver from their homepage.I was able to install nvidia370 again and the boot is fine now.And i removed the libs and now Steam does work.I got no error now at the nvidia screen :)

kil1mple gravatar imagekil1mple ( 2016-10-08 08:29:54 -0600 )edit

Holy shit, you scared me in the first place,... i'm happy to hear it's working now! Can anybody explain why this happened?

jake gravatar imagejake ( 2016-10-08 09:52:18 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2016-10-07 22:01:22 -0600

Seen: 976 times

Last updated: Oct 08 '16